15" MacBook Pro not running smoothly..

Discussion in 'Mac Basics and Help' started by GreenStripe, Jun 25, 2010.

  1. GreenStripe macrumors member

    Joined:
    Jan 11, 2009
    #1
    This 15" MacBook Pro is abotu a year and a half old, and I'm running into a bit of a problem. For most things, it's fine. I use it for photoshop, aperture, etc. And a couple months ago, I used to play Team Fortress 2 and other games in bootcamp.

    But now these games have come out for the Mac and they run sluggishly at best. It's VERY choppy. At first I thought this was something to do with the program itself, but after doing a lot of research, no one else seemed to be complaining abotu the problems I was.

    This leads me to believe that there is a problem with my computer.. So how can I test this? Are there any ways to speed up my mac? Maybe an update, or a fresh install, or something?

    Thanks.
     
  2. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #2
    Have you tried changing the settings of the game? Try e.g. low graphic settings. If it still lags, then it has something to do with your computer
     
  3. GreenStripe thread starter macrumors member

    Joined:
    Jan 11, 2009
    #3
    Yea, I have. I run it on pretty much the lowest settings and it doesn't work. I've tried it with both graphics cards as well
     
  4. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #4
    Do you have any other games to try? Have you updated to 10.6.4? You could try repairing permissions and stuff
     
  5. CubeHacker macrumors 65816

    CubeHacker

    Joined:
    Apr 22, 2003
    #5
    There is supposedly a bug with the current Nvidia drivers in 10.6.4 that cause steam games to run poorly, at least according to Valve. Also check out the following thread:

    http://forums.macrumors.com/showthread.php?t=950296

    Might be a workaround for now.
     

Share This Page