15" Macbook Pro Unibody possible problem at startup?

Discussion in 'MacBook Pro' started by Gumbygreenphoto, Jan 21, 2009.

  1. Gumbygreenphoto macrumors newbie

    Joined:
    Jan 6, 2009
    Location:
    Kentucky
    #1
    Possible silly question:

    I have an almost one month old MBP 15" Unibody. Is it supposed to try to get the DVD drive to spin at startup? There is no CD or DVD in the slot.

    Thanks.
     
  2. Crash1234 macrumors regular

    Joined:
    Oct 22, 2008
    #2
    I"m pretty sure that's normal. Not something I normally pay attention to, but if I'm remembering correctly, my mbp does this, my iMac does this, and so does my whitebook.
     
  3. acfusion29 macrumors 68040

    acfusion29

    Joined:
    Nov 8, 2007
    Location:
    Toronto
  4. Niiro13 macrumors 68000

    Joined:
    Feb 12, 2008
    Location:
    Illinois
    #4
    It's normal for any computer. I believe the BIOS checks to see if anything is attached to that specific port on the logic board.

    Just like how on Windows-based computers, the BIOS lists out the drives at the beginning. The actual hardware isn't smart enough to know whether something's plugged in without sending some sort of signal to check.
     
  5. kastenbrust macrumors 68030

    kastenbrust

    Joined:
    Dec 26, 2008
    Location:
    North Korea
    #5
    Its normal for every computer.
    Think: if it broke, and the DVD drive didnt spin on startup, how would you reinstall your Apple Leopard operating system?

    :)
     
  6. Gumbygreenphoto thread starter macrumors newbie

    Joined:
    Jan 6, 2009
    Location:
    Kentucky
    #6
    Thanks all. It's what I thought. When I asked the question at the local Apple Store recently, the salesperson thought it was a problem and suggested bringing the machine to the Genius Bar.
     

Share This Page