15" Retina MacBook Pro display problem

Discussion in 'MacBook Pro' started by Jimmy Guphanti, May 29, 2015.

  1. Jimmy Guphanti macrumors 6502

    Joined:
    Mar 29, 2011
    #1
    Hello,

    I just bought a new top of the line 15" 2015 MacBook Pro and I am already having a problem with using a display. My friend uses a MacBook Air in clamshell mode connected via HDMI to an ASUS display. When she touches the keyboard or clicks the mouse, the mac wakes up and sends a picture to the ASUS display and it works fine. I am trying to do the same thing, also with an ASUS display with HDMI, but the display does not behave right. I hit a key on my USB keyboard or click the mouse, and the ASUS monitor wakes up but says "HDMI NO SIGNAL" on a blue screen and goes back to sleep, and then comes back on a second later and says the same thing. After 5 or so times of doing this, the display from the Mac comes through and it works.

    The difference between me and my friend is that she just uses HDMI but I use a Belkin thunderbolt dock and plug the HDMI into that. If I plug the HDMI right into the port on the MacBook pro, it wakes from sleep properly for the most part, but all the devices on the hub lose power for a split second coming out of or going to sleep even though the hub has AC power.

    Sorry for this being so long winded.

    Any ideas?

    Thanks.
     
  2. Jimmy Guphanti thread starter macrumors 6502

    Joined:
    Mar 29, 2011
    #2
    Also when I power the computer on from being off it does the same thing--it is not limited to sleep mode.
     

Share This Page