15" rMBP & 27" iMac slow & slower on WiFi

Discussion in 'Mac Basics and Help' started by Hankmac, Jan 23, 2014.

  1. Hankmac macrumors member

    Hankmac

    Joined:
    Apr 15, 2013
    #1
    I have a late 09 27" iMac and mid 12 15" Retina MB Pro both with 16 Gbs ram and both on Mavericks on a Cox cable modem Arrris TM502G with a 4th gen Airport Time Capsule as a WiFi router about 75' away and it worked acceptably. Shortly after installing Mavericks on the iMac I noticed it getting slower and slower but didn't have time to investigate and then the other day I couldn't take it any longer because even the Cox site was slow loading. So I ran the Cox speed test and found the iMac was max 7 Gbps but usually much slower and since I don't use the rMBP at home I didn't run any tests on it. I called Cox and they apologized and said there was an upgraded modem, a Cisco DPQ 3212 that was over twice as fast and sent me one. Got install help from Cox and ran Cox speed test. The rMBP download is 10 MBps and uploads is 20 Mbps while the iMac is 0.78 Mbps download and 7 Mbps upload. I checked the Network conifig on both Apples and both are identical. When I Option click on the WiFi menulet both Apples show a Transmit Rate of 19 to 39 on Channel 1 2.4GHz. I've Reset Safari, rebooted the computers, modem and AirportTC. Cox test show the modem is OK. So what could it be on the iMac? Any tips appreciated.
    Thanks
    Hank
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
    Well Hank you might first would want to open System Preferences->Network pane and then click the 'Advanced' button. It should open in a pop-down and open in the mini-tab 'Wi-Fi' and there delete any other networks besides you own to connect to when home.

    Now also open /Applications/Utilities/Airport Utility.app and get into your Airport Time Capsule. When you click once on the Capsule icon look at the side-pop for wireless clients and see if someone is leaching off your wireless network.

    If everything works out try the next steps to reset you wireless connection.

    1. Go back into System Preferences->Network pane and at the top of the pane is the 'Location' toggle bar and use that to 'Edit' locations to make a new custom Location (like Home, etc.) and to save that new name make sure you click the 'Apply' button in the main Network pane window to totally save this new Location.

    2. Go back into Airport Utility and go back into Time Capsule and click the 'Edit' button to get into it;s Advanced window 'Wireless' and there select the toggle for 'Wireless Options' and set up a 5 GHz network and a 2.4 GHz network radio mode and give your 5GHz network an extended name so you can tel the 2.4 from 5 GHz. Then back in OS X System Preferences->Network pane and use that to join the 5 GHz network for higher network speeds.

    See if this helps, Good Luck.
     

Share This Page