15" rMBP keeps droping WiFi - what to check or do please?

Discussion in 'MacBook Pro' started by Freida, Sep 3, 2013.

  1. Freida macrumors 65816

    Joined:
    Oct 22, 2010
    #1
    Hello guys,

    in the last few days my rMBP started to act weird when it comes to WiFi. It constantly drops the signal or can't find it. Or when it finds it it can't connect or tells me password is incorrect.
    My iPhone can connect ok and my gf's dell can also connect.
    We have airport express station (5 months old)

    I have tried to delete network preferences, I have resetted PRAM, I have repaired HDD and repaired permission but the issue is still happening.

    When I go to Airport utility it sometimes finds the station sometimes doesn't. And sometimes it doesn't find it but the laptop is connected to the computer.

    Could you please tell me what can I check myself before I drag myself to the apple store and wait for 1 week before they are free, please?

    I suspect its either software related or something as if it was hardware then it wouldn't see the network at all, right? And also it works on / off

    What do you think, please?
     
  2. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #2
    Hello,

    you could try changing the wifi channel of your Airport Express.

    Try desactivating Blutooth if it is on.

    See : http://support.apple.com/kb/HT1365

    If this does not fix the problem, you could then delete the configuration of the current connexion.
    (this needs deleting network preferences AND others elements in Keychains).
     
  3. red321red321 macrumors regular

    Joined:
    Jun 3, 2013
    #3
    take it to an apple store and have them run thorough tests, i had this same problems and got my rmbp replaced, the new one doesnt have this problem
     
  4. Freida thread starter macrumors 65816

    Joined:
    Oct 22, 2010
    #4
    Well, I wouldn't like having my replaced as I don't want LG screen. When I got this I had to go through 4 replacement because of the ghosting issue so that is the last resort to go through :)

    I have removed the airport express from airport utility and that for some reason seems to fix it which is a bit strange but it works now. I would expect that that has nothing to do with it but for some reason it seems that it had.

    I hope it will stay fine and hope Mavericks will fix these little bugs also.

    Another issue i keep getting is screen flickering but that is only when I switch resolution. Best for retina works without any issues so I guess that is software too :) (i hope)
     

Share This Page