15 seconds before I can use an app?

Discussion in 'Apple Watch' started by aaronchow, Jun 3, 2015.

  1. aaronchow macrumors regular

    Joined:
    Sep 29, 2007
    #1
    Just curious. I just got my Apple Watch today and I have only loaded two apps on it ("Things" and "Hours" app). When I tried to open those apps to quickly create a task or to start or stop a timer, is it normal that the app won't respond u until at least 15 or so seconds? I am reading the posts here but it seems like this only happens to me, so I'm deciding if I should reset both my watch and iPhone to see if this will fix it.
     
  2. andrewstirling macrumors regular

    Joined:
    May 19, 2015
    #2
    I don't have my watch yet but this seems to be normal for third party apps. Can't see it improving until apple allows developers to install apps directly to the watch instead of running on the phone.
     
  3. aaronchow thread starter macrumors regular

    Joined:
    Sep 29, 2007
    #3
    Thanks. I hope Apple will allow developers to code native apps on the Apple Watch soon. I find myself continuing to use my iPhone or MacBook Air because the Apple Watch apps take too long to start up. One time when I was waiting for Things to start, the Watch's screen went to sleep so I have to quickly twist my hand to bring the screen back, and it was kind of annoying. I was hoping that my watch would make my workflow more efficient, but I probably won't use the Apple Watch versions until Apple grants native app development on the Watch platform. Thanks for replying again.
     
  4. andrewstirling macrumors regular

    Joined:
    May 19, 2015
    #4
    Yeah based on what I've read I don't intend to install many watch apps at all when I get my watch. Essentially opening an app on your watch sends a signal to your phone via Bluetooth. Your phone then opens the app and sends the data back to your watch. It's clunky.
    Hopefully there'll be an announcement in Mondays keynote.
     
  5. paulgandersman macrumors regular

    Joined:
    Jul 4, 2010
    #5
    Have you updated your watch yet (through the Apple Watch app on your phone)? Because that significantly improves 3rd party app load times.
     
  6. jonfarr macrumors 6502a

    jonfarr

    Joined:
    Jun 29, 2012
    Location:
    Portland
    #6
    i had the reverse affect and now have worse 3rd party load times after the update...
     
  7. Michael CM1 macrumors 603

    Joined:
    Feb 4, 2008
    #7
    I don't know about 15 seconds, but it can take a few. As others said, it should improve once developers get an SDK and as they get more familiar with the watch. There's an obvious difference between, say, native apps like Workout and Activity and third-parties like Target or Starbucks.
     
  8. T-Will macrumors 6502a

    T-Will

    Joined:
    Sep 8, 2008
    #8
    I've had apps take 15+ secs to be responsive, but usually when I see this happening, it occurs with any 3rd party app I try opening, which to me is indicating an overall communication issue between the Watch and iPhone and that point in time. If all things are working as expected, most 3rd party apps should only take a few seconds to open.
     
  9. amirite, Jun 4, 2015
    Last edited: Jun 4, 2015

    amirite macrumors 6502a

    Joined:
    Aug 17, 2009
    #9
    This slowness is unacceptable. It's something we'd expect from Apple's competitors as the norm and wouldn't even raise an eyebrow. It's not something we'd expect from Apple. It's a bigger problem than Apple maps ever was.

    I love the Watch but there are way too many things that scream "rushed to market". E.g., I don't care about the heart rate monitoring change, but the fact that a couple of weeks after launch they made such a big change when they've had maybe a year of testing real hardware internally is shocking.
     
  10. Anya B macrumors 6502

    Anya B

    Joined:
    Jul 20, 2013
    #10
    I had the same problem with Dark Skies and it worked a charm after I uninstalled and re installed it. The uninstall literally takes a minute so try it out.
     

Share This Page