1604 error continues

Discussion in 'Jailbreaks and iOS Hacks' started by newfie, Jan 4, 2012.

  1. newfie macrumors newbie

    Joined:
    Jan 4, 2012
    #1
    Hi, I know this gets asked a lot but any help getting past this 1604 error would be great.

    -IP4 currently on JB 4.3.3 with 2.10.04
    - running tiny umbrella TSS server and have SSh back to 4.0.2
    - made custom ispw 5.01 with pwnage
    - booted in dfu mode and tried to restore to my custom ispw
    - got error 11 the first time, since then getting 1604

    Things I've tried from here and the world of google
    - clearing my hosts
    - dfu, revovery and straight
    - 2 USB cables on 2 macs
    - re create a new custom ispw and try it all again
    - moving some files from my library which didn't go well
    - now I get the error "AppleMobileDeviceHelper quit unexpectedly" but I can fix that later

    Any help is great, time to get some sleep so tomorrow after work I can bang my head on this for a 3rd night. Thanks for any tips.
     
  2. Crystal-RX, Jan 4, 2012
    Last edited: Jan 4, 2012

    Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #2
    Since you are upgrading to 5.0.1, you do not need to run TSS server because Apple is signing it currently. So, shut TU's TSS server down and make sure the hosts point to Apple server. This is the reason you are getting 1604 error.

    Also, follow this guide on fixing this error too;

    http://www.redmondpie.com/fix-1604-1600-itunes-error-during-ios-4.0-custom-firmware-restore/
     
  3. boshii macrumors 68040

    boshii

    Joined:
    Jul 6, 2008
    Location:
    Atlanta, GA
    #3
    I was trying to restore my iPad earlier and kept getting error 1600. Doing this helped me.

    Go to your hosts file and look for the line that looks like this:

    74.208.10.249 gs.apple.com

    Make it look like this:

    # 74.208.10.249 gs.apple.com

    Save it and try to restore again.
     
  4. newfie thread starter macrumors newbie

    Joined:
    Jan 4, 2012
    #4
    Thanks, I tried an OSX equivalent of the fix you linked to but didn't fix me error and actually may have mentioned other files that made it so my iPhone was no longer detected until I replaced the files. If I don't run the TS server in TinyUmbrella won't my baseband get updated? Wanted to preserve so I have the possibility of using the gevey. Oh and I'll try editing my hosts file, but last time I did tinyumbrella immediately put the entries back so I went to terminal and did a sudo pico on the file but that didnt help. I'll try to give it a go tonight again. Thanks for any help
     
  5. newfie thread starter macrumors newbie

    Joined:
    Jan 4, 2012
    #5
    Hi everyone, I've tried all the above, keep getting error 1604, then 1600, tried putting into pwnd dfu mode with redsn0w, then got error 3104 and last time I tried to use the stock firmware with tu running with the intention to jailbreak after and get error 11. Been reading all the tutorials and help on the error that I can find but getting nowhere, thanks for anything to fix whatever I'm making a mess of.
     
  6. ipader macrumors member

    Joined:
    Jan 28, 2010
    #6
    try updating to the latest version of itunes. After updating, I no longer was getting the 1604 error and was able to complete the jailbreak
     
  7. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #7
    Pwnage is designed to preserve your BB, you don't have to run TU in that case.
    Also reset your host to apple, let TU do it, connect phone, start TU, advanced tab uncheck set host to cydia, exit TU.

    You can also make a custom ipsw with redsn0w, it wil be a ipsw without BB, you can restore with that as well, but than you have to jailbreak with redsn0w afterwards.
    Now alt-restore your custom ipsw in itunes.
     
  8. Asuran macrumors newbie

    Joined:
    Apr 5, 2011
    #8
    I am having the same problem and tried doing this with TU, restarted it, and then started TSS before, but when going to restore with a custom IPSW I get a error 11. I have been using Redsn0w for all of this too. I am thinking about trying PwnageTool any suggestions?
     
  9. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #9
    To restore a custom ipsw you need to be in DFU mode, did you do that?

    Don't use TSS with custom ipsw
     
  10. Asuran macrumors newbie

    Joined:
    Apr 5, 2011
    #10
    Ok so I used PwnageTool from beginning to end, and it worked. I was using Redsn0w before and I don't like that program. I have always had better success on a mac with PwnageTool.

    Now after jailbreaking with the PwnageTool from this link http://www.iclarified.com/entry/index.php?enid=19014 Would I still need to run corona in cydia to get the most updated bug fixes? Thanks and sorry for jacking the thread.
     
  11. newfie thread starter macrumors newbie

    Joined:
    Jan 4, 2012
    #11
    Finally got it working by letting iTunes download the update directly from Apple but not install and then running simple mode in Pwnage letting it pickup the file from the iTunes installer package. Not sure if it was he downloaded file or something weird in advanced mode, thanks for the suggestions and sorry about the delays trying suggestions, been spending hospital time.
     

Share This Page