16GB upgrade issues with mid-2011 on High Sierra

Discussion in 'Mac mini' started by hamncheeze, Jan 25, 2018.

  1. hamncheeze macrumors newbie

    hamncheeze

    Joined:
    Jan 25, 2018
    Location:
    Canada
    #1
    Hey folks, I am a forum newbie here, but I have lurked silently for a while. I have a mid-2011 Mac mini 2.5GHz i5 running the latest OS, High Sierra 10.13.3. Up until yesterday it was in original config with 4GB of memory. I bought a 16GB kit from OWC and with shipment to Canada it took a while to arrive. I did the OS update on Tuesday, and then installed the memory on Wednesday. 24 hours with the 16GB and I had no shortage of crashes, pretty much 1 per hour. Mostly kernel panics causing restarts or GPU restarts. I ran the Apple Diagnostics (hold D after power on) and everything checked out. I also reset the SMC and PRAM. No improvement.

    Today I put the original 4GB back in and I have had a perfectly stable machine all day. No crashes, no reboots. I contacted OWC and they are going to refund me for the cards after I send them back. They wanted me to DL the Rember program to test the memory but I don't see the point, the fact that I have a stable system today makes it obvious the aftermarket memory is the issue. My questions:

    1) Even though 16GB is reportedly OK with the mid-2011 Mini is it possible that High Sierra is making it no compatible. Has anyone done a RAM upgrade after running 10.13?

    2) Is it worth trying another brand of memory such as Crucial? I seem to see more people recommending Crucial than other brands. If I do this, I think I'll try 8MB. That would probably be sufficient since I don't use it for gaming. Mostly routine use, photo management and editing, and MS Office (not installed currently).

    Any other thoughts?

    Thanks!
    --- Post Merged, Jan 25, 2018 ---
    Here is a copy of one of the kernel crashes:


    Wed Jan 24 13:37:27 2018

    *** Panic Report ***
    panic(cpu 0 caller 0xffffff800716e339): Kernel trap at 0xffffff7f89bcde38, type 14=page fault, registers:
    CR0: 0x000000008001003b, CR2: 0x00000000009c96ec, CR3: 0x000000000b754000, CR4: 0x00000000000626e0
    RAX: 0xffffff8026adb6b0, RBX: 0xffffff802e2f5030, RCX: 0x0000600000000000, RDX: 0xffffff81e4e7e000
    RSP: 0xffffff92108ebd30, RBP: 0xffffff92108ebd40, RSI: 0x0000000000000000, RDI: 0x00000000009c966c
    R8: 0xffff9fffffffffff, R9: 0xffffff80078c0180, R10: 0xffffff80078bed14, R11: 0x0000000000000000
    R12: 0xffffff802e2f5030, R13: 0xffffff8026aff2e0, R14: 0xffffff8026afd290, R15: 0xffffff800706e200
    RFL: 0x0000000000010086, RIP: 0xffffff7f89bcde38, CS: 0x0000000000000008, SS: 0x0000000000000010
    Fault CR2: 0x00000000009c96ec, Error code: 0x0000000000000000, Fault CPU: 0x0, PL: 0, VF: 1

    Backtrace (CPU 0), Frame : Return Address
    0xffffff92108eb7e0 : 0xffffff800704f606
    0xffffff92108eb830 : 0xffffff800717c654
    0xffffff92108eb870 : 0xffffff800716e149
    0xffffff92108eb8f0 : 0xffffff8007001120
    0xffffff92108eb910 : 0xffffff800704f03c
    0xffffff92108eba40 : 0xffffff800704edbc
    0xffffff92108ebaa0 : 0xffffff800716e339
    0xffffff92108ebc20 : 0xffffff8007001120
    0xffffff92108ebc40 : 0xffffff7f89bcde38
    0xffffff92108ebd40 : 0xffffff800716b8f3
    0xffffff92108ebd60 : 0xffffff800706abf1
    0xffffff92108ebde0 : 0xffffff8007069e6f
    0xffffff92108ebe30 : 0xffffff7f87d74899
    0xffffff92108ebed0 : 0xffffff7f87d779af
    0xffffff92108ebf40 : 0xffffff80075fa978
    0xffffff92108ebfa0 : 0xffffff8007001906
    Kernel Extensions in backtrace:
    com.apple.kec.pthread(1.0)[71C5BFFF-88C9-3420-8F52-029FAFF0866D]@0xffffff7f87d71000->0xffffff7f87d7ffff
    com.apple.driver.AppleHV(1.0)[1B4F136C-9465-379A-8D80-878A4AA2AF87]@0xffffff7f89bca000->0xffffff7f89bd2fff

    BSD process name corresponding to current thread: com.apple.WebKit

    Mac OS version:
    17D47

    Kernel version:
    Darwin Kernel Version 17.4.0: Sun Dec 17 09:19:54 PST 2017; root:xnu-4570.41.2~1/RELEASE_X86_64
    Kernel UUID: 18D901F1-4A03-3FF1-AE34-C26B2732F13C
    Kernel slide: 0x0000000006c00000
    Kernel text base: 0xffffff8006e00000
    __HIB text base: 0xffffff8006d00000
    System model name: Macmini5,2 (Mac-4BC72D62AD45599E)

    System uptime in nanoseconds: 245222440096
    last loaded kext at 148291457931: com.apple.filesystems.smbfs 3.2.1 (addr 0xffffff7f87cc3000, size 434176)
    loaded kexts:
    com.apple.filesystems.smbfs 3.2.1
    com.apple.driver.AppleBluetoothMultitouch 92
    com.apple.driver.AudioAUUC 1.70
    com.apple.driver.AppleHWSensor 1.9.5d0
    com.apple.driver.ApplePlatformEnabler 2.7.0d0
    com.apple.driver.AppleTyMCEDriver 1.0.3d2
    com.apple.driver.AGPM 110.23.30
    com.apple.filesystems.autofs 3.0
    com.apple.driver.AppleMikeyHIDDriver 131
    com.apple.driver.AppleMikeyDriver 280.12
    com.apple.driver.AppleGraphicsDevicePolicy 3.16.21
    com.apple.AGDCPluginDisplayMetrics 3.16.2
    com.apple.driver.pmtelemetry 1
    com.apple.iokit.IOUserEthernet 1.0.1
    com.apple.driver.AppleUpstreamUserClient 3.6.4
    com.apple.driver.AppleMCCSControl 1.5.3
    com.apple.driver.AppleHDAHardwareConfigDriver 280.12
    com.apple.iokit.IOBluetoothSerialManager 6.0.2f2
    com.apple.kext.AMDLegacyFramebuffer 1.6.0
    com.apple.driver.AppleHDA 280.12
    com.apple.driver.ApplePolicyControl 3.16.21
    com.apple.Dont_Steal_Mac_OS_X 7.0.0
    com.apple.driver.AppleHV 1
    com.apple.kext.AMDRadeonX3000 1.6.0
    com.apple.driver.AppleOSXWatchdog 1
    com.apple.driver.eficheck 1
    com.apple.driver.AppleMuxControl 3.16.21
    com.apple.driver.AppleIntelSlowAdaptiveClocking 4.0.0
    com.apple.driver.AppleSMCPDRC 1.0.0
    com.apple.driver.AppleFIVRDriver 4.1.0
    com.apple.driver.AppleLPC 3.1
    com.apple.driver.AppleThunderboltIP 3.1.1
    com.apple.driver.ACPI_SMC_PlatformPlugin 1.0.0
    com.apple.kext.AMD6000Controller 1.6.0
    com.apple.driver.AppleIntelHD3000Graphics 10.0.4
    com.apple.driver.AppleIntelSNBGraphicsFB 10.0.4
    com.apple.iokit.IOBluetoothUSBDFU 6.0.2f2
    com.apple.driver.AppleIRController 352
    com.apple.driver.AppleFileSystemDriver 3.0.1
    com.apple.AppleFSCompression.AppleFSCompressionTypeDataless 1.0.0d1
    com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0
    com.apple.BootCache 40
    com.apple.filesystems.hfs.kext 407.30.1
    com.apple.driver.AppleFWOHCI 5.5.8
    com.apple.driver.AirPort.Brcm4331 800.21.30
    com.apple.driver.AppleSDXC 1.7.6
    com.apple.iokit.AppleBCM5701Ethernet 10.3.1
    com.apple.driver.AppleAHCIPort 329
    com.apple.driver.AirPort.Brcm4360 1220.18.1a2
    com.apple.driver.AppleRTC 2.0
    com.apple.driver.AppleACPIButtons 6.1
    com.apple.driver.AppleHPET 1.8
    com.apple.driver.AppleSMBIOS 2.1
    com.apple.driver.AppleACPIEC 6.1
    com.apple.driver.AppleAPIC 1.7
    com.apple.driver.AppleIntelCPUPowerManagementClient 220.0.0
    com.apple.nke.applicationfirewall 183
    com.apple.security.quarantine 3
    com.apple.security.TMSafetyNet 8
    com.apple.driver.AppleIntelCPUPowerManagement 220.0.0
    com.apple.IOBufferCopyEngineTest 1
    com.apple.driver.AppleBluetoothHIDKeyboard 203
    com.apple.driver.AppleHIDKeyboard 203
    com.apple.driver.IOBluetoothHIDDriver 6.0.2f2
    com.apple.driver.AppleMultitouchDriver 1204.13
    com.apple.driver.AppleInputDeviceSupport 1201.8
    com.apple.kext.triggers 1.0
    com.apple.iokit.IOSerialFamily 11
    com.apple.driver.DspFuncLib 280.12
    com.apple.kext.OSvKernDSPLib 526
    com.apple.driver.AppleSSE 1.0
    com.apple.driver.AppleSMBusController 1.0.18d1
    com.apple.iokit.IOFireWireIP 2.2.8
    com.apple.iokit.IOAcceleratorFamily2 376.6
    com.apple.iokit.IOSurface 209.2.2
    com.apple.AppleGPUWrangler 3.16.2
    com.apple.driver.AppleSMBusPCI 1.0.14d1
    com.apple.driver.AppleGraphicsControl 3.16.21
    com.apple.kext.AMDSupport 1.6.0
    com.apple.AppleGraphicsDeviceControl 3.16.21
    com.apple.iokit.IOSlowAdaptiveClockingFamily 1.0.0
    com.apple.driver.AppleHDAController 280.12
    com.apple.iokit.IOHDAFamily 280.12
    com.apple.iokit.IOAudioFamily 206.5
    com.apple.vecLib.kext 1.2.0
    com.apple.driver.AppleThunderboltEDMSink 4.1.2
    com.apple.driver.IOPlatformPluginLegacy 1.0.0
    com.apple.driver.IOPlatformPluginFamily 6.0.0d8
    com.apple.kext.AMDLegacySupport 1.6.0
    com.apple.iokit.IONDRVSupport 517.22
    com.apple.iokit.IOGraphicsFamily 517.22
    com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport 6.0.2f2
    com.apple.iokit.IOBluetoothHostControllerUSBTransport 6.0.2f2
    com.apple.iokit.IOBluetoothHostControllerTransport 6.0.2f2
    com.apple.iokit.IOBluetoothFamily 6.0.2f2
    com.apple.driver.usb.IOUSBHostHIDDevice 1.2
    com.apple.driver.usb.cdc 5.0.0
    com.apple.driver.usb.networking 5.0.0
    com.apple.driver.usb.AppleUSBHostCompositeDevice 1.2
    com.apple.driver.usb.AppleUSBHub 1.2
    com.apple.filesystems.hfs.encodings.kext 1
    com.apple.driver.AppleThunderboltDPInAdapter 5.0.2
    com.apple.driver.AppleThunderboltDPOutAdapter 5.0.2
    com.apple.driver.AppleThunderboltDPAdapterFamily 5.0.2
    com.apple.driver.AppleThunderboltPCIDownAdapter 2.1.3
    com.apple.driver.AppleXsanScheme 3
    com.apple.iokit.IOAHCIBlockStorage 301.40.2
    com.apple.driver.AppleThunderboltNHI 4.5.6
    com.apple.iokit.IOThunderboltFamily 6.6.3
    com.apple.iokit.IOFireWireFamily 4.6.8
    com.apple.driver.AppleUSBMergeNub 900.4.1
    com.apple.iokit.IOEthernetAVBController 1.1.0
    com.apple.iokit.IOAHCIFamily 288
    com.apple.iokit.IO80211Family 1200.12.2
    com.apple.driver.mDNSOffloadUserClient 1.0.1b8
    com.apple.driver.corecapture 1.0.4
    com.apple.driver.usb.AppleUSBEHCIPCI 1.2
    com.apple.driver.usb.AppleUSBUHCIPCI 1.2
    com.apple.driver.usb.AppleUSBUHCI 1.2
    com.apple.driver.usb.AppleUSBEHCI 1.2
    com.apple.driver.usb.AppleUSBHostPacketFilter 1.0
    com.apple.iokit.IOUSBFamily 900.4.1
    com.apple.driver.AppleUSBHostMergeProperties 1.2
    com.apple.driver.AppleEFINVRAM 2.1
    com.apple.iokit.IOHIDFamily 2.0.0
    com.apple.driver.AppleEFIRuntime 2.1
    com.apple.iokit.IOSMBusFamily 1.1
    com.apple.security.sandbox 300.0
    com.apple.kext.AppleMatch 1.0.0d1
    com.apple.driver.AppleFDEKeyStore 28.30
    com.apple.driver.AppleEffaceableStorage 1.0
    com.apple.driver.AppleKeyStore 2
    com.apple.driver.AppleUSBTDM 439.30.4
    com.apple.driver.AppleMobileFileIntegrity 1.0.5
    com.apple.iokit.IOUSBMassStorageDriver 140.30.1
    com.apple.iokit.IOSCSIBlockCommandsDevice 404.30.2
    com.apple.iokit.IOSCSIArchitectureModelFamily 404.30.2
    com.apple.driver.AppleCredentialManager 1.0
    com.apple.driver.KernelRelayHost 1
    com.apple.iokit.IOUSBHostFamily 1.2
    com.apple.driver.usb.AppleUSBCommon 1.0
    com.apple.driver.AppleBusPowerController 1.0
    com.apple.driver.AppleSEPManager 1.0.1
    com.apple.driver.IOSlaveProcessor 1
    com.apple.iokit.IOBufferCopyEngineFamily 1
    com.apple.driver.DiskImages 480.30.2
    com.apple.iokit.IOStorageFamily 2.1
    com.apple.iokit.IOReportFamily 31
    com.apple.iokit.IOTimeSyncFamily 650.5
    com.apple.iokit.IONetworkingFamily 3.4
    com.apple.driver.AppleACPIPlatform 6.1
    com.apple.driver.AppleSMCRTC 1.0
    com.apple.driver.AppleSMC 3.1.9
    com.apple.iokit.IOPCIFamily 2.9
    com.apple.iokit.IOACPIFamily 1.4
    com.apple.kec.Libm 1
    com.apple.kec.pthread 1
    com.apple.kec.corecrypto 1.0

    EOF

    System Profile:
    Network Service: Ethernet, Ethernet, en0
    Thunderbolt Bus: Mac mini, Apple Inc., 22.2
    Boot Volume File System Type: hfs
    Memory Module: BANK 0/DIMM0, 8 GB, DDR3, 1333 MHz, 0x0000, -
    Memory Module: BANK 1/DIMM0, 8 GB, DDR3, 1333 MHz, 0x0000, -
    USB Device: USB 2.0 Bus
    USB Device: Hub
    USB Device: BRCM20702 Hub
    USB Device: Bluetooth USB Host Controller
    USB Device: USB 2.0 Bus
    USB Device: Hub
    USB Device: IR Receiver
    Serial ATA Device: TOSHIBA MK5065GSXF, 500.11 GB
    Model: Macmini5,2, BootROM MM51.007B.B00, 2 processors, Intel Core i5, 2.5 GHz, 16 GB, SMC 1.75f0
    Graphics: Intel HD Graphics 3000, Intel HD Graphics 3000, Built-In
    Graphics: AMD Radeon HD 6630M, AMD Radeon HD 6630M, PCIe, 256 MB
    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xE4), Broadcom BCM43xx 1.0 (5.106.98.102.30)
    Bluetooth: Version 6.0.2f2, 3 services, 27 devices, 1 incoming serial ports
     
  2. California, Jan 26, 2018
    Last edited: Jan 26, 2018

    California macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #2
    Uh, I believe the mid 2011 Mac Mini was an i7 2.5 with the HD3000 graphics card. Only the 2012 2.5 was an i5... with the HD4000 better graphics... which one are you using?



    *****

    Oh, you have the 2.5 i7 2011. All 2011 Minis and laptops have problematic graphics cards. I ran 16gbs on my 2011 mini (not the quad, though) with no problems. Probably bad ram. It happens.
     
  3. keysofanxiety, Jan 26, 2018
    Last edited: Jan 26, 2018

    keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
  4. California macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #4
    Am I missing something here? 32gbs of ram? Where exactly would that ram go in a Mac Mini 2011?
     
  5. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #5
    ****, I read it as a 2011 iMac. Boy I need some more coffee.
     
  6. California macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #6
    That would be amazing if they made 16gb ram chips... that worked...
     
  7. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #7
    Heh, there are 16GB 1600MHz SODIMMs but sadly they won't work, even if the CPU supports 32GB RAM. The 2012 quad MM/cMBP's CPU does support 32GB RAM so in theory it should work but the Logic Board/controller doesn't support or recognise 16GB DIMMs. :(
     
  8. hamncheeze thread starter macrumors newbie

    hamncheeze

    Joined:
    Jan 25, 2018
    Location:
    Canada
    #8
    Thanks for the replies everyone. I'm going to return the 16GB kit to OWC and order an 8GB of Crucial from Amazon. 8GB will be plenty for this old girl.
     
  9. frank4 macrumors regular

    frank4

    Joined:
    Oct 17, 2011
    #9
    Never had a problem with the graphics on my 2011 Mini. Except it won't let me rotate the image 90 degrees on my 2 monitors when I rotate them from landscape to portrait orientation (it can do this OK with just 1 connected monitor).
     
  10. titangears, Jan 26, 2018
    Last edited: Jan 26, 2018

    titangears macrumors member

    titangears

    Joined:
    Nov 8, 2005
    #10
    8 GB Crucial works pretty well in mine.
     
  11. uller6 macrumors regular

    uller6

    Joined:
    May 14, 2010
    #11
    I'm using 16 GB Crucial in my base 2011 Mac mini 2.3 and I've never had any issues. Running 10.13.3 now.
     
  12. chabig macrumors 601

    Joined:
    Sep 6, 2002
    #12
    Their request is very fair. You can’t just assume the memory is bad. It’s not always easy to get memory chips well seated in their sockets. Maybe you didn’t get it quite right with the new memory but did it right when you put the old back in. Commonly, memory troubleshooting starts with a recommendation to reseat the chips.
     
  13. BigMcGuire Contributor

    BigMcGuire

    Joined:
    Jan 10, 2012
    Location:
    California
    #13
    This is what I had to do on my 2011 Mac Mini. 8GB. And yes, it's great. I can have XCode opened, Word, Chrome with 20 tabs and it's happy. CPU comes on now and then but it's doing great going out to my dual monitors. :)
     
  14. hamncheeze thread starter macrumors newbie

    hamncheeze

    Joined:
    Jan 25, 2018
    Location:
    Canada
    #14
    Just an update:

    Bought a Crucial 8GB kit (2x4GB) direct from Crucial and everything seems to be working well. Had a small issue after replacement where no media would start to play (iTunes, YouTube, etc) but a reboot with a PRAM reset seemed to cure the problem. Speed seems great, can easily run multiple applications and have music playing in the background and hop around from app to app with no lag.

    For those asking about the original OWC 16GB kit, I had tried re-seating the cards in the slots, swapping the lower to the upper, multiple times. It did not seem to matter, crashes were inevitable.
     

Share This Page