17" hi res mbp screen buzz noise is driving me insane!

Discussion in 'MacBook Pro' started by jjahshik32, May 5, 2008.

  1. jjahshik32 macrumors 603

    Joined:
    Sep 4, 2006
    #1
    That's all I hear is that high pitched sound in my quiet room! I'm going to go down to the apple store and talk to a genius about it and try to get it exchanged for a macbook.. I'm tired of all these problems on the mbp line.. with the magsafe led light not coming on to these screen buzz noises...

    Man I love the 17" hi res but the buzz noise.. gets to me..
     
  2. PeterKW macrumors newbie

    Joined:
    Apr 4, 2008
    #2
    Yeah, it's really a pity. It's the best screen I have seen so far on a portable. Much better than the VAIO high res screen.

    I just hope Apple is going to fix it in the next revision.
     
  3. jjahshik32 thread starter macrumors 603

    Joined:
    Sep 4, 2006
    #3
    I'm trying to see if I can get used to the sound as its hard to hear and its only clearly audible when your ear is near the right top speaker but just knowing that sound is there is messing with me. I think I keep looking for that sound and that's the problem..

    I know the 15" mbp that I had didnt have this problem but I freakin love this screen size/quality to give it up...

    I'll just have to see if I can use this 17" mbp for another week before making the final judgement.

    And the odd part is that I just noticed it now after a few days later. So its got to be mostly in my mind because even though I'm 1 1/2 ft away from the screen and with the screen turned off sometimes I hear that buzz noise and its all in my mind.

    On a side note my friend came over to my house today and he brought his white macbook 2.0ghz core 2 duo model and when I put my ear next to the machine I hear a sizzling/buzz noise thats even worse (I'm guessing the processor since its in the middle area). So I guess all notebooks make some sort of noise.
     
  4. jjahshik32 thread starter macrumors 603

    Joined:
    Sep 4, 2006
    #4
    After I zapped the pram the noise is gone for a good 10 seconds then when leopard loads its there again.. I wonder if leopard is causing this issue?? And maybe a simple efi upgrade could fix this?
     

Share This Page