17" iMac startup problems.

Discussion in 'iMac' started by Brasshat, Oct 29, 2010.

  1. Brasshat macrumors newbie

    Joined:
    Sep 30, 2010
    #1
    I have a 17" G5 (early model). recently the computer is having starting problems. Often I just get a black screen and the fan speeds up. Sometimes the computer actually runs ok for short while, then freezes. Reboot results in blank screen. The computer also does not accept a boot disk in the slot drive most times.

    I have swapped the internal drive and also swapped out the ram sticks, so the problem isn't there.

    I have tried booting from an external drive, I have reset the pram and any other system reset I can think of. I have also tried a different keyboard. Whatever I do the computer usually doesn't work, although occasionally it runs for a while.

    Computer spec: 17" iMac G5. 1.6ghz. OSX 10.4 256 mb ram.
     
  2. Brasshat thread starter macrumors newbie

    Joined:
    Sep 30, 2010
    #2
    Tried again today. Now it won't even start up at all. All I get is the white light showing on front, no start-up chime, then a black screen and fan noise, which speeds up after a while. I cannot insert a boot disk in the slot either.

    I have opened up the back again and checked for blown capacitors. I am at a loss what to try now, any suggestions please.
     
  3. RollTide macrumors 6502

    RollTide

    Joined:
    Mar 9, 2006
    Location:
    Alabama
    #3
    I have a 17 inch intel model and had similar issues about a year ago. I unplugged it and plugged back in, but if you have opened it you have (hopefully) already done that.
     

Share This Page