192 kHz USB output at MBA (2012)

Discussion in 'MacBook Air' started by kal800, Mar 1, 2017.

  1. kal800 macrumors newbie

    Joined:
    Apr 12, 2014
    #1
    Hi,

    I connected my Mac to Cambridge Dacmagic 100 dac using USB cable. DAC is able to input data from 44,1 up to 192 kHz, but I am not able to output it on my system. Using MIDI settings I am able to select 96 kHz maximum frequency. Any idea how can it forced? USB 3.0 which is installed in my notebook is capable to transfer such bandwidth, so is DAC, so it seems that it is an OS problem. Any ideas?
     
  2. DblHelix macrumors 6502

    Joined:
    Mar 19, 2009
    #2
    I believe you would need to change the mac to USB class 2 mode.

    http://bfy.tw/ANhP
     
  3. kal800 thread starter macrumors newbie

    Joined:
    Apr 12, 2014
    #3
    how can I do it, tried to google it, but could not find a manual to do so...
     
  4. simonmet macrumors 65816

    simonmet

    Joined:
    Sep 9, 2012
    Location:
    Sydney, New South Wales
    #4
    Do you have 192 kHz content?

    Reason being that sample rates should generally be set to match the source content. The DACMagic has its own upsampling techniques during conversion to analogue and these are designed to do the best it can given the source material. Mis-representing the source won't really improve the sound.

    Problem is I'm not sure if OS X automatically switches because of the way it handles system audio. There may be a mode in which it does but I'm currently Mac-less so I can't confirm. CDs are normally 44 kHz while video is normally 48. So unless you're happy to keep switching which one do you choose?

    Personally I find it pretty easy to keep an eye on the midi settings and switch if necessary. You might be able to find a menu bar app or something to make it even quicker to check and change.
     
  5. kal800 thread starter macrumors newbie

    Joined:
    Apr 12, 2014
    #5
    I do, I downloaded 192/24 flacs and VOX Player to handle that. The thing is, that when I plug DAC in, the LED indicating bitrate shows 96 regardless of the content.
     
  6. casperes1996 macrumors 65816

    casperes1996

    Joined:
    Jan 26, 2014
    Location:
    Horsens, Denmark
    #6
    As far as I know you have to manually pick it in the MIDI menu. By default it is set to 24-bit integer @44.1KHz, whereas Windows' default is 48KHz.
    To get sort of "the best of both world", I recommend 88.2KHz. That way you're getting exactly double of what music usually is, meaning that the quality is the same as if you match the source, as it just reads the same signal exactly twice, and that there's no reading in between signals. With content that's 48KHz, you'll still be in a position where you check in between signals, and therefore don't get all the signals that are in the source, but since you check more often, you'll get less loss.
    Alternatively, if video is your focus, same argument but 96KHz instead, with the music quality then getting lost signals, but again, fewer than at 48KHz.
    You could also go 192 for video focus if your sound setup supports it, achieving same effect as the above, but even fewer dropped signals when playing 44.1KHz content.

    For the OP - Sorry, no clue, mate. But I just noticed something rather weird. In my MIDI settings, I used to have a 192KHz option, but now, my max is 96KHz too. Don't really know what that's about.
     
  7. Bart Kela, Mar 1, 2017
    Last edited: Mar 1, 2017

    Bart Kela macrumors 6502a

    Bart Kela

    Joined:
    Oct 12, 2016
    Location:
    No Service
    #7
    I used the search parameters "dacmagic manual" and the first Google search result is this page with manual PDFs in various languages.

    Page 22 describes how to switch the device to USB Audio 2.0 mode.

    You need to brush up on your Internet searching skills.

    It's been such a long time since I've done this, I forgot if you need a special application to play 192kHz files, or if the standard apps (Quicktime Player or iTunes) will play these files.

    I do know that Audirvana and Amarra both will play 192kHz/24 bit files. These days, my DacMagic is collecting dust. My old Mac mini is connected to a Teac receiver that supports 192kHz, but I'm content to use optical audio, so I'm only getting 96kHz. That's good enough for me. I could switch to USB, but I can't be bothered anymore.

    Good luck.
     
  8. kal800 thread starter macrumors newbie

    Joined:
    Apr 12, 2014
    #8
    did not help. The device is switched to USB 2.0, and it says that Mac OS supports that format natively, without additional drivers, but still I can get only 96. Perhaps there is an issue with my USB cable...
     
  9. esatamacmodular macrumors member

    Joined:
    Nov 27, 2014
    #9
    I thought CDs were 16 bit/ 44.1kHz ... are you suggesting your Teac receiver up-samples to 96kHz coming out of the mac mini audio port? or are you using USB and playing higher quality 96kHz files? The "optical audio" part is confusing me as it makes me think CD.
     

Share This Page