1st Gen AirPort Extreme setup issues.

Discussion in 'Mac Accessories' started by Mini125, Oct 8, 2013.

  1. Mini125 macrumors newbie

    Joined:
    Oct 8, 2013
    #1
    Hello all,

    New to this forum however have always come here for research and always help me and I'm sure this task won't be either, and it's just me.

    I bought a brand new AirPort Extreme at the weekend, new and sealed. It's a first gen. I've also bought a new DSL modem to use it with. The modem in question is a TP Link TD8816.

    When I plug the airport in the usual green light comes in followed by a flashing amber.. I've set the modem up and can connect to internet via Ethernet. If I plug the modem into the wan port of the airport and my Mbp into a Ethernet port I can access the internet too.. The trouble is setting up the airport using utility. It will find the airport under other wifi device and try and connect but will fail. Sometimea saying an update is required of 7.6.3 with this version of utility and see support website. Apple support site says to go to utility to update.. They won't help as out of warranty even though brand new. Catch 22 really.

    Sometimes it will haut say an unexpected error has occurred. All the time I can still use the airport via Ethernet. Have trie airport utility inn iphone and iPad with no results.

    How can I update it so I can setup? Can't setup without update. Can't update without setup? Found a airport express firmware updated and according to apple there is a extreme one. I can't find it.

    Many thanks
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    I think the issue is you need the older version of Airport Utility to recognize that Extreme. Try following this guide to DL and install the old version.
     
  3. Mini125 thread starter macrumors newbie

    Joined:
    Oct 8, 2013
    #3

    Thanks for the link to that. All goes well and places the old utility onto my Desktop, however as I'm using 10.9 Mavericks it does not want to work. Im going to downgrade to 10.8 I think to get it working, it was on my list of things to do, to do a clean install of 10.8 anyway.

    Any other options?
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    Sorry... not that I can think of.
     

Share This Page