1st Gen iMac Power Problems

Discussion in 'iMac' started by Jordan6, Dec 2, 2008.

  1. Jordan6 macrumors regular

    Joined:
    May 21, 2006
    #1
    Ihave a 1st Gen pre-isight iMac...i was already having problems with putting it to sleep, every time I put it to sleep it would shut off.

    So now one day I try to turn it on and it never turns on for a few days after NUMEROUS attempts:(..one day I finally got it to work.I never put it to sleep/shut down again(LOL)....one day the screen just flickers like it was shook or something and then it just becomes snowy like one of those old TV's but wit color...I turn it off and then the thing hasnt turned back on since.(been off for about 1-2 months):rolleyes::mad:

    Basically like there is NO power whatsoever...I have no idea what caused how it got like that and why.I've searched high and dry all over the forum, google,yahoo,etc.no definitive answer

    ANYBODY can help???
     
  2. Jordan6 thread starter macrumors regular

    Joined:
    May 21, 2006
  3. Reflow macrumors 68000

    Reflow

    Joined:
    Mar 30, 2005
    Location:
    NJ/PHL
    #3
    Did you happen to look at apple's support site? There was Repair Extention on your model, but I think you a little to late to qualify for since it started in September 2005 and November 2006. Maybe if you push hard enough with apple they will only charge you for the labor. Since I had an emac motherboard replaced recently even though it was a year to late on the repair program.
     
  4. Jordan6 thread starter macrumors regular

    Joined:
    May 21, 2006
    #4
    That's EXACTLY the problem...Im gonna call them and see what happens.

    thanks for the help
     
  5. Reflow macrumors 68000

    Reflow

    Joined:
    Mar 30, 2005
    Location:
    NJ/PHL
    #5
    Post back to lets us know how you made out..
     

Share This Page