1st Gen iPod touch with 1604 error. Can't get iTunes to restore. Help?

Discussion in 'iPod touch' started by reubs, Sep 11, 2010.

  1. reubs macrumors 68000

    Joined:
    Jun 22, 2006
    #1
    My 1st gen iPod touch just stopped working a few weeks ago. It was fine in the car when I was listening to something on it, then when I tried it a few minutes later to input an appointment, the screen wouldn't come on.

    Later, I tried messing with it a bit more, and I got a blank screen with lines, and later I got a solid, bright green screen.

    When I tried hooking it up to my MBP (latest SL, iTunes 9 at the time), I got the restore notice, and then I was told that it couldn't be restored. I tried a number of times to reboot, and I could never get to the apple logo. Just a blank screen and then the green screen again.

    After upgrading to iTunes 10, I tried the whole process again, even going so far as to delete all of the .ipsw files in my iTunes library. I'm still having the same problems, and I'm wondering if anyone has any info to share about how to fix this problem. Google has been less than helpful, and I'm running out of ideas here.

    Thanks for any help!
     
  2. reubs thread starter macrumors 68000

    Joined:
    Jun 22, 2006
    #2
    I'm going back and trying this again on the off chance that something may have happened to make this work.

    So I'll ask it again. Has anyone seen this issue before? There's a lot about 1604 errors, but there's not much info on how to fix it. Some say it's hardware, and some say it's software.

    Any thoughts?
     

Share This Page