1st generation iPhone, screen partially not working

Discussion in 'iPhone Tips, Help and Troubleshooting' started by QMdude, Mar 14, 2010.

  1. QMdude macrumors member

    Joined:
    Dec 30, 2009
    #1
    I have a 1st generation iPhone that was unlocked and jailbroken with ZiPhone. One day I was typing a text message/using internet (can't recall specifically) and a bunch of random keys popped up (as they do when you type) even though I had not pressed anything, and since then a portion of the screen no longer works. This portion is (in the context of text messaging), the top row of the keyboard, and the area where you have the actual message (hence I cannot press 'send').

    I repeatedly tried the reset technique involving holding the home button and power button, but had no results. Recently I have reset the home screen and now have a "how to rearrange home screen icons" thing in the middle of my screen whenever I turn the phone on, and I cannot press "ok" due to the problems in the screen. Any idea what the problem may be, or what I can do about it?

    Thanks!!!!
     
  2. UngratefulNinja macrumors 68000

    UngratefulNinja

    Joined:
    May 9, 2009
    Location:
    Pennsylvania
    #2
    What happens when you pushed and held the power and home button at the same time (you didn't explain what happened when you tried it)
     
  3. QMdude thread starter macrumors member

    Joined:
    Dec 30, 2009
    #3
    My bad. It resets the phone (all info still in there, not a complete reset if such a thing exists), but nothing changed; screen still has the issue
     
  4. carlgo macrumors 68000

    Joined:
    Dec 29, 2006
    #4
    This is a common problem. Mine is dead about 1/3 of the way down, about a 1/2 inch strip across the screen.

    Apple doesn't offer any help. There are no repair parts, so you are expected to throw it away and buy a new iPhone!

    I have searched the www for repair ideas. One post said you can take it apart and clean the contacts, that the problem is corrosion. When my contract is up, I'll attempt the repair. Nothing to lose at that point. If it works, I can use it as an iTouch.
     
  5. QMdude thread starter macrumors member

    Joined:
    Dec 30, 2009
    #5
    I read somewhere that this could be due to the jailbreaking....anyone know of any way to completely reset the phone?
     
  6. QMdude thread starter macrumors member

    Joined:
    Dec 30, 2009
    #6

    Any luck?

    Thanks!
     

Share This Page