1st time DNS lookup always fails

Discussion in 'MacBook Pro' started by maw4bc, Jul 26, 2012.

  1. maw4bc macrumors regular

    Joined:
    Apr 11, 2009
    #1
    Every time I open my MBP I get "DNS lookup failed", it doesn't matter what web browser I use and it is always on the initial use of the internet. After a minute or some I can then surf normally for as long as I am connected to the internet. But once I close my laptop and open it back up it will do the same thing. This is a recent problem. Any suggestions?
     
  2. FearGhost macrumors member

    FearGhost

    Joined:
    Apr 4, 2011
    Location:
    Cambridge, UK
    #2
    How long do you leave the MBP to wake up before you try and use a web browser?

    I suspect that while the Mac sleeps it drops it's IP address, and when it wakes it re-acquires a new IP (including DNS) from your DHCP server.

    To test this you could try adding a static IP, Gateway and DNS IP's.

    Have you tried waiting a few minutes for DHCP to do its thing before you try using a browser?
     
  3. maw4bc thread starter macrumors regular

    Joined:
    Apr 11, 2009
    #3
    I usually get right at it. But I have never had this problem in the past. I have always been able to pull up websites immediately.
     
  4. MadTester macrumors regular

    MadTester

    Joined:
    Mar 24, 2012
    #4
    Have you tried manually setting the DNS ip's? When I'm wired in I go through my airport base station (as this is my internal network router) and not straight to the router which is just my DHCP server. either way hopefully that should remedy your issue regardless of your machine dropping the DHCP client address and getting a new one when you make your MBP.

    HTH...:)
     
  5. ryane67 macrumors member

    Joined:
    Jun 13, 2012
    #5
    How long has it been going on? Do you have any other computers (or maybe putting your phone on the wifi, if possible) to test with?

    I'd think it could be a problem with the router more than your laptop.
     
  6. steve-p macrumors 68000

    steve-p

    Joined:
    Oct 14, 2008
    Location:
    Newbury, UK
    #6
    That would be my guess, too. I had intermittent DNS issues for weeks affecting my MBP which turned out to be a problem with the DNS servers my ISP was running. Changing the router to use 8.8.8.8 for DNS fixed it. Just rebooting the router could fix it though.
     
  7. Pete1983 macrumors newbie

    Joined:
    Jul 26, 2012
    #7
    MacBook Pro DNS Issue

    I had a very similar issue with my laptop and it drove me nuts for a couple months. We went through 2 routers and couldn't figure it out then I called our internet provider and they said mac sucks buy windows ! well that isn't going to happen so lots of research and I finally installed open dns free version problem solved it loads fast and never loses the ip. I believe there is a desktop app but I just put it into the ip box in my routers firmware now all our computers load well. It turns out the problem was on the internet providers end because now my router gets results from open dns. Don't get the paid version free works just fine. By the way I am not very technical so hopefully this makes sense.

    Pete
     

Share This Page