1TB External Hard Drive Error

Discussion in 'Mac Accessories' started by DaniHungary, Dec 3, 2014.

  1. DaniHungary macrumors newbie

    Joined:
    Jul 25, 2014
    #1
    Hey there guys!

    I have a problem, and I hope someone can help. I bought a 1TB Samsung external HDD for my sister, but she forgot to format it, so after a week I had to. I tried, but I had the following problem.
    When I try to format it in Disk Utility, it says that "unable to unmount disk"
    I had that problem before too, so i ejected it through Terminal (not sure which command worked) some diskutil force unmountDisk stuff. After that, I tried to format it again, but then the error message was "Unable to write in the last block of device" I googled a lot, found some solutions for that problem, but none of them worked for me
    -tried to format it through recovery mode : "Unable to unmount disk"
    -tried on windows dos disk utility : there was 0kb on the disk, "no data on hdd" or something like that error.
    -tried everything on disk utility, in terminal, still no solution.

    I can see the hard drive in disk utility, just no partition under it. Someone said that on Linux it's possible to format it, but I've never had Linux, and I dont want to install one to a virtual box. Only if it's my last chance.


    here is the disk info. I would really really appreciate if someone could help me somehow. Thank you in advance!
     
  2. ColdCase macrumors 68030

    Joined:
    Feb 10, 2008
    Location:
    NH
    #2
    Sounds like either a disk or enclosure defect. If you can, try another enclosure.

    In disk utility, did you select the drive and then select erase?
     
  3. DaniHungary thread starter macrumors newbie

    Joined:
    Jul 25, 2014
    #3
    thank you for the reply!
    It's not in a case, it's built this way, so i can't open it. Or if I do, i have to brake the glue.

    Yeah i tried that one too. Same error.
     
  4. ColdCase macrumors 68030

    Joined:
    Feb 10, 2008
    Location:
    NH
    #4
    I'd suggest returning or exchanging the drive under warranty. Or contact Samsung tech support.
     
  5. MacRobert10 macrumors 6502

    Joined:
    Nov 24, 2012
    #5
    You don't want to end up like me in this thread:

    http://forums.macrumors.com/showthread.php?t=1655890

    I'm stuck with that lemon because I opened it up when I could have probably RMA'd it. Oddly it still works but it still has the delay problem.

    I would definitely not open the case at all. The only thing that's unclear to me is whether or not you ever really tried to delete the existing partition on the HD and/or create a new partition on the HD before doing anything else. That might be worth a shot. If the partition itself is in a format the unit can't understand it may need to be done away with first.

    If nothing else works, if it was me I'd either return it or take it to the store with a portable and show them the problem.
     
  6. DaniHungary thread starter macrumors newbie

    Joined:
    Jul 25, 2014
    #6

    It doesn't have a partition it right now, that might be the biggest problem. Sadly I cannot take it back, so that's not an option either. But thanks for your help!

    Every idea is appreciated, either i find a solution, or i say goodbye to this hdd. :)
     
  7. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #7
    OP wrote above:
    [[ Every idea is appreciated, either i find a solution, or i say goodbye to this hdd. ]]

    I'll try to help. This advice may be useful -- or may be of no use to you at all.

    Try this, in the exact order presented:

    1. Shut down computer (all the way off)

    2. Reboot computer -- DO NOT attach the external drive yet.

    3. When you get to the finder, connect the external drive.

    4. Important questions: does a drive icon mount on the desktop? Or do you get any other kind of error message or alert?

    If the drive appears on the desktop, try this next:
    a. Open Disk Utility

    b. Move the DU window so that you can still see and "reach" the drive icon on the desktop

    c. Select the drive by clicking on it ONE TIME in DU's window. Click the erase tab to make the tab visible, but do not click anything else just yet.

    d. Now, reach over (in the finder) and "grab" the drive's icon, and drag it to the trash. Does it dismount from the desktop?

    e. If so, NOW click the erase buttons and see what happens.

    Again, may not even work for you, but worth a try...

    Some additional thoughts:
    This drive may have some kind of "hidden" or "protected" partition it on, that prevents DU from re-initializing it.
    If that's the case, you'll have to find a way to "destroy" this protected partition.

    You might look at this page:
    http://www.overclock.net/t/1227597/how-to-secure-erase-your-solid-state-drive-ssd-with-parted-magic
    Although the instructions pertain to SSD's, it might also work on an HDD.
     
  8. DaniHungary thread starter macrumors newbie

    Joined:
    Jul 25, 2014
    #8


    Thanks but it's not visible on the desktop. It doesn't have partitions or anything.

    [​IMG]

    Here, in disk utility it appears, but nowhere else. I will look into that parted magic solution too, thanks! :)
     

Share This Page