1TB hard drive stopped being recognized

Discussion in 'Mac Basics and Help' started by rsherid, Mar 20, 2010.

  1. rsherid macrumors member

    Joined:
    Jul 9, 2009
    #1
    I've had a 1TB external drive (Samsung Story) working wonderfully as a Time Machine backup for the last month.

    It had been unplugged for the last couple days, but I plugged it in today to do a back-up. Unfortunately, it wasn't recognized. It stills lights up and makes noises so I don't think it's dead, but no matter which USB port I put I use or how many times I restart, my MacBook won't recognize it anymore.
     
  2. rsherid thread starter macrumors member

    Joined:
    Jul 9, 2009
    #2
    Nevermind, it was just recognized after 20 minutes of nothing. Is this bad?
     
  3. sl1200mk2 macrumors 6502

    Joined:
    Oct 17, 2006
    #3
    I've had some issues with external USB drives before and this fixed them:

    • To fix this, hold the COMMAND key while booting. The external drive should mount and appear on the desktop.

    I'm not sure if this is your same issue or not (could be a drive or USB port going bad), but sounds similar to what I was having and the above always fixed it.

    Good luck -
     
  4. clarkjames macrumors newbie

    Joined:
    Mar 21, 2010
    #4
    been having a similar issue with mine- a freecom 400gb, takes about 5 minutes to appear, and connects as usb 1.0, but after 20 minutes it reconnects as usb 2.0 and works fine until it's turned off again

    after plugging the drive into a powered USB hub it works at full speed (instantly) every time

    so I think it might have something to do with the power supply?
     

Share This Page