2.0.2 Still Killed all my Apple Store Apps

Discussion in 'iPhone Tips, Help and Troubleshooting' started by edtorious, Aug 19, 2008.

  1. edtorious macrumors 65816

    edtorious

    Joined:
    Aug 14, 2007
    Location:
    San Diego, California
    #1
    So, I upgraded last night and synced and everthing was fine until this morning, all my 3rd party apps are not working again! :rolleyes: Oh well, back to square one. :(
     
  2. Raid macrumors 68020

    Raid

    Joined:
    Feb 18, 2003
    Location:
    Toronto
    #2
    Ok first take a deep breath.

    Repeat as needed. You're going to be ok.

    Now turn off your phone and turn it on again. Chances are the apps will work.
     
  3. Hustle macrumors 6502a

    Joined:
    Jul 29, 2007
    Location:
    United Kingdom
    #3
    This happened to me. Simply write down all the names of the Apps and then delete them from your computers iTunes.

    Now go to the App Store on your iPhone and download all of them again. The ones you have paid for will not charge you again. A box appear advising you that you have already purchased this App and can download it for free again by clicking Ok.

    :)
     
  4. edtorious thread starter macrumors 65816

    edtorious

    Joined:
    Aug 14, 2007
    Location:
    San Diego, California
    #4
    I am actually calm :cool: because it happened to me couple of time already on 2.0.1 but I was hoping it got fixed on 2.0.2 but don't worry I'm not mad ;) maybe just disappointed. Anyway, did that already but still not working :rolleyes:
     
  5. edtorious thread starter macrumors 65816

    edtorious

    Joined:
    Aug 14, 2007
    Location:
    San Diego, California
    #5
    Yes, I'll probably do just that and I'm familiar with all other solutions suggested before when this was happening on 2.0.1 but I was hoping that 2.0.2 fixed that :rolleyes: Oh well, I guess we'll have to wait for a fix awhile longer. :(
     
  6. edtorious thread starter macrumors 65816

    edtorious

    Joined:
    Aug 14, 2007
    Location:
    San Diego, California
    #6
    So I restored and just resynced and worked and I'm hoping it will stay that way. :rolleyes:
     
  7. gpfradgley macrumors newbie

    Joined:
    Jan 19, 2008
    #7
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 2_0_2 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5C1 Safari/525.20)

    I love the iPhone I was there on day one and q'd up and got mine then on 3g launch day got an upgrade. The new software is a complete joke!!!!! I commute 2 hours every day and this phone is becomming more useless everyday!!!! Last night I upgraded to 2.0.2 and waited 2 hours for it to update. This morning I went to work and the iPod function worked fine. Showed someone a app that I had and it just crashed. Now for the second time my iPhone is showing no music. No apps will launch and I'm sitting here on the way home with no music complaining!!! This SHOULD NOT HAPPEN!!!! Why are we all putting up with this rubbish??? Why don't we all demand a refund??? And wait till they get it right!!!!
     
  8. darkfiber macrumors 6502a

    darkfiber

    Joined:
    Jul 13, 2008
    Location:
    Columbus, OH USA
    #8
    This has worked for me since I did it 5 days ago...

    http://forums.macrumors.com/showpost.php?p=6055900&postcount=161

    following those steps my iPhone apps and music and videos have been working fine even through the 2.0.2 upgrade. I have even downloaded apps via the App Store on the phone itself and through iTunes. The key (I think) is when I downgraded iTunes to 7.7.0
     
  9. edtorious thread starter macrumors 65816

    edtorious

    Joined:
    Aug 14, 2007
    Location:
    San Diego, California
    #9
    Oh well, after a few days of working, my 3rd party apps are crashing again! :rolleyes::mad: When I get home I'll try fixing it again, I can't even show off my iphone to my friends with all the great apps! :mad: I'm glad macrumors did a headline news about this so that we can show apple that this is becoming a serious problem. Too bad some people has already resorted to lawsuit, but then I can't blame them.... :(
     
  10. rockinrocker macrumors 65816

    rockinrocker

    Joined:
    Aug 21, 2006
    #10
    i'm also having the no apps will run/disappearing media issue.

    taking it to apple store this afternoon as i already went through the whole restore from backup bit.
     
  11. 0wen macrumors newbie

    Joined:
    Jul 11, 2008
    #11
    A new iPhone will not fix the problem as it seems to be something wrong with both 2.0.2 and the new iTunes 7.7.1.11. I had this problem with 2.0.1 and it still continues with 2.0.2 and iTunes. If I update an app from iTunes it seems to be about 90% chance it will kill all my downloaded apps. If I use the App Store from the iPhone itself, it seems to be about the same. So my only solution has been to either not sync anything app related or a daily restore starting with a clean iPhone and then adding all my apps, music, movies, etc. This is really a pain and it is a shame that after a few weeks of this problem being known, Apple still has not found a solution.
     
  12. darkfiber macrumors 6502a

    darkfiber

    Joined:
    Jul 13, 2008
    Location:
    Columbus, OH USA
    #12
    You guys really should try my solution that I posted here....

    http://forums.macrumors.com/showpost.php?p=6055900&postcount=161

    I did this 6 days ago and my phone has been running fine ever since.

    You can keep restoring your phone over and over again, keep taking it back to Apple for a new one, but if you keep on using iTunes 7.7.1, I think you are going to continue to have these issues. For sure Apple needs to fix this, but if you want your phone to keep working until that permanent fix arrives, then give what I did a try. It sure beats restoring the phone over and over.
     
  13. rockinrocker macrumors 65816

    rockinrocker

    Joined:
    Aug 21, 2006
    #13
    OK, i'll give that a shot tomorrow.

    just to double check, when you say your library and everything was still there after deleting 7.7.1 in favor of 7.7.0, that would mean apps too, right? (i got netshare when it was up and want to make sure it's still gonna be around)

    thanks.
     
  14. rockinrocker macrumors 65816

    rockinrocker

    Joined:
    Aug 21, 2006
    #14
    well, that seems to have done it. everything's more or less fine now.
    except,

    1) for seem reason i can only delete one app at a time per boot up. it's really strange. i tried to delete a bunch of the useless ones i was just kind of playing around with, and when i rebooted the phone, all but one came back. so i had to delete 'em one at a time, then reboot.

    2) it takes itunes almost a full five minutes before the phone comes up under devices.

    backups are down to just a few minutes now, so that's good.
     
  15. hnn macrumors newbie

    Joined:
    Jul 9, 2008
    #15
    Simple solution to killed Apps!

    Hi,

    On the Apple Discussion about this same topic, the following solution has been posted by several person. I have not tried it, but will do the next time it happens to me!

    Hi sll, this is what worked for me:
    I have iTunes 7.7.1.11 (latest)
    I have iPhone 3g ver 2.0.2 of the firmware (lastest)

    My downloaded custom apps all of a sudden would simply start and then crash back to the home screen.


    Steps to fix:
    1. Connect iPhone to laptop
    2. Sync using iTunes
    3. In iTunes deauthroise computer (Store | Deauthorise Computer) 4. Sync again (you will get errors about your custom apps and paid-for music, just ignore these errors) 5. In iTunes authrorise your computer again (Store | Authorise Computer) 6. Sync again

    All good for me - all apps now working - all music available Cheers


    The discussion itself is HUGE, and has been viewed by 14,000 persons (!), so it seems it is quite frequen. You can find it at this link:

    http://discussions.apple.com/thread.jspa?messageID=7942143#7942143
     
  16. Chodite macrumors 6502a

    Chodite

    Joined:
    Sep 23, 2007
    Location:
    Baltimore, MD
    #16
    Ugh what a nightmare 2.02 has been for my iPhone 3G.
    All of the above fixes don't seem to fix my apps all crashing and it's still taking 30+ minutes to "back up" my iPhone each time. WTF is this mess?!? I'm *this* close to throwing the thing out the window. Soooo frustrated :(
     

Share This Page