2.0.2 update kills wireless works OK after downgrade

Discussion in 'Apple TV and Home Theater' started by mackthen, Jun 4, 2008.

  1. mackthen macrumors newbie

    Jun 4, 2008
    I have a really strange problem with my AppleTV. I had been using it with ethernet no problem with the version 2.0.x software, but I decided to go with wireless, but when I try and set up wireless after unplugging the ethernet it cant find ANY networks.

    All my other wireless devices see mine and several neighbours networks at reasonably high strength, yet the AppleTV in

    settings -> general ->Network -> Configure Wireless

    just shows the screen with the big 'OTHER' button and doesn't list any networks, not mine or my neighbours. If I enter the SSD manually it I just get a screen saying "There was a problem connecting to the Network, Check your settings and try again."

    I tried reverting to factory settings, and because its an older AppleTV it downgrades itself to version 1.0, and the wireless suddenly works fine, the setup screen shows all the networks around me and I can join my network no problem.

    Thinking the factory reset had solved the problem I update the software, wirelessly, and restart once 2.0.2 has installed and its back to square one, the AppleTV acts like there's no wireless networks available.

    Surely it can't be the hardware when version 1.0 works OK. Is there any known issues with 2.0.2 that might be causing a conflict that wasn't there in 1.0.

    Any help would be appreciated as I'm at my wits end. The AppleTV is well out of warranty and I hate the thought of never being able to use the wireless if I want to move it.

    Also what kind of cost do Apple charge for servicing out of warranty machines?
  2. tom1971 macrumors 6502a

    May 15, 2007
    Strange, I never had problems with the 2.02 upgrade.
    However there is another thread here mentioning that you should use a dedicated channel for your wireless router rather than putting it on "automatic".
  3. mackthen thread starter macrumors newbie

    Jun 4, 2008
    Thanks for that. I think I tried that but I'll maybe give it another go.
    The fact that I'm not picking up any of my neighbours networks makes me think it's nothing to do with my router and something borked on the AppleTV itself. I even plugged in my old router and put it right next to the AppleTV and it didn't pick that up either.

Share This Page