2.0 Apps Start to Open, Then CRASH

Discussion in 'iPhone' started by lilnyc, Jul 14, 2008.

  1. lilnyc macrumors 6502a

    lilnyc

    Joined:
    Jun 5, 2007
    #1
    For some reason, all of my apps from the Apple Apps Store start to open, then crash back to the start-up screen.

    This started this morning because I had AIM up and working. Over the weekend, while installing the apps, a few did this, but the problem was resolved with an iPhone reboot. Now nothing's working. I can't open ANY of my apps except those that came with the 3G iPhone.

    Please help! :(
     
  2. komiothebeat macrumors 6502

    komiothebeat

    Joined:
    Jul 8, 2008
    Location:
    Corona, CA
    #2
    i had this happen with aim, it would load and then crash before showing my friends, what i ended up doing was uninstalling the app, and then reinstalling and have been using flawlessly ever since, i also did a restore to get the lastest firmware ending in 47 instead of 45.
     
  3. slicecom macrumors 68020

    Joined:
    Aug 29, 2003
    Location:
    Toronto, Canada
    #3
    Open iTunes, go to Store > Authorize Computer, re-enter your Apple ID and Password, then sync your iPhone. ;)
     
  4. newyorksole macrumors 68030

    Joined:
    Apr 2, 2008
    Location:
    New York.
    #4
    I had to individually delete all of my apps on the phone and then resync on the computer to have them not crash anymore.
     
  5. dacreativeguy macrumors 68020

    Joined:
    Jan 27, 2007
    #5
    Try resetting your iphone (hold down both the home and power buttons for several seconds). This helped for me. For other apps, delete them on the iphone and reinstall from the iphone.

    Another problem is that some apps downloaded (for the first time) from the apps store on the iphone don't get backed up to itunes on your computer. I'm sure we'll see some updates to the firmware and itunes within a few weeks and some of these minor irritations will be sorted out.
     
  6. Scott6666 macrumors 65816

    Scott6666

    Joined:
    Feb 2, 2008
    #6
    reboot iphone; they will work again. Happens periodically. Guess not all apps are written correctly. Maybe Apple needs a stronger sandbox.
     
  7. tucker101uk macrumors member

    Joined:
    Jul 7, 2008
    Location:
    Sussex, UK
    #7
    This happened to me with monkeyball...

    Was sorted with a reboot.
     
  8. robhedin macrumors regular

    Joined:
    Dec 14, 2006
    #8
    Actually, the crash logs tend to indicate that it's generally not a problem in the app, but in the OS. There are many apps that really don't do much of anything at all (flashlight or moo for example), and yet still exhibit the same problem.

    Personally, I tend to think that there is an issue with the provisioning system (DRM) (which is why standard apps work, but 3rd party apps are failing).

    rob.
     
  9. doug0365 macrumors member

    Joined:
    Jun 23, 2008
    #9
    I had this situation twice happen to me and rebooting the phone didn't fix it until I removed an app and re-installed it then reboot the phone and that would fix it.. but Like I said this happend to me twice... I know its still early but so far the Third party apps have been very buggy Hopefully a a fix will come out as soon as the whole iphone 3g madness calms down
     
  10. lilnyc thread starter macrumors 6502a

    lilnyc

    Joined:
    Jun 5, 2007
    #10
    UPDATE: I think I solved the problem. I had to AUTHORIZE my iTunes to work with my computer. So ANY computer that you use synch your iPhone apps to seems to require being authorized. After authorizing it, my apps work fine.

    Go to iTunes' Store menu (in the toolbar)
    Select Authorize Computer

    Prior to doing this, rebooting the iPhone and restoring it did not help. Also, deleted apps would not resynch due to the authorization issue.

    >> Update II - My apps crashed again for no reason. THIS time, simply rebooting the iPhone resolved the problem.

    Thanks to everyone who helped! I hope this is the solution.
     
  11. calvy macrumors 65816

    Joined:
    Sep 17, 2007
    #11
    I had this problem today too, out of nowhere, on my 3g iphone. Native apps worked fine, but nothing I installed via the app store would work. It would start to load and crash. So, i found this thread, tried authorizing my computer, and resynched...no luck. So one by one I deleted all my apps on the phone, then in iTunes, and synched again. I reinstalled a few of the apps and all seems to be back in working order. Except I have to re download everything. Pain in my a$$.
     

Share This Page