2.0 ... or jailbroken 1.1.5 ... I don't know.

Discussion in 'iPod touch' started by asskick3r, Aug 7, 2008.

?

What should I update to/stay/jailbreak

Poll closed Aug 17, 2008.
  1. Stay with jailbroken 1.1.5/4

    5.6%
  2. Upgrade to 2.0 and stay official

    55.6%
  3. Upgrade to 2.0 and THEN jailbreak with winpwn (with installer 4)

    38.9%
  1. asskick3r macrumors regular

    asskick3r

    Joined:
    Jun 9, 2008
    Location:
    "Somewhere ... In las vegas"
    #1
    I was thinking to upgrade to 2.0.... but also sticking with jailbroken 1.1.5.
    I am going to jailbreak 2.0... but only when winpwn comes bundled with installer.

    All I'm asking is... Do you guys think 2.0 is worth it? Or do you think it could hold me over untill the release of winpwn 2.5 and installer 4?
    Thanks.

    (There is also a poll that might help my decision)
     
  2. Chris Rogers macrumors 6502a

    Chris Rogers

    Joined:
    Jul 8, 2008
    Location:
    my house
  3. =Shadow= macrumors member

    Joined:
    Aug 6, 2008
    #3
    Depends what you want. If you want hundreds of free third party apps and games including the ability to customize your iPod, then stick to 1.1.4 JB. The downside to this is that less and less people are staying on 1.1.4, so don't expect too many new apps over installer.

    If you decide to go for the 2.0 FW, since that is where all the new apps are at, than you should Pwn it as well. This is so that you can use apps like WinterBoard and Customize, as well as being able to get all the latest games and apps from the appstore. It's the best of both worlds that way.

    IMHO, I would choose a pwned 2.0 iPod, so that's where I will place my vote.
     
  4. Kohkane macrumors 6502a

    Joined:
    Jun 10, 2008
    #4
    Right now I'm on 2.01 and I'm going to wait till tomorrow :p
     
  5. asskick3r thread starter macrumors regular

    asskick3r

    Joined:
    Jun 9, 2008
    Location:
    "Somewhere ... In las vegas"
    #5
    Good point... But I don't think there is a winpwn for 2.0 yet.

    I will ponder what you said... but until I see installer 4 up and running GOOD Then I will go through with whatever is most beneficial for me. (Not saying all I care about is me)
    Thanks for the input!
     
  6. asskick3r thread starter macrumors regular

    asskick3r

    Joined:
    Jun 9, 2008
    Location:
    "Somewhere ... In las vegas"
  7. gregdrummeraz macrumors 6502

    Joined:
    Jun 7, 2007
    Location:
    Glendale, az
  8. Eric Isaacson macrumors 6502

    Joined:
    Jul 30, 2008
    #8
    2.0 is my vote.

    I love the App Store and I look forward to what's coming in the future.

    Eric
     
  9. axe-to-grind macrumors newbie

    Joined:
    Jun 13, 2008
    #9
    I have a jailbroken 2.2 1st gen ipod touch at the moment though i'm not sure i'll keep it that way. the appstore eliminates a lot of the advantages of jailbreaking. (i used quick pwn)
     

Share This Page