2.01 Update killed Wi-Fi and Network

Discussion in 'iPhone' started by Jowl, Aug 5, 2008.

  1. Jowl macrumors 6502

    Joined:
    Apr 13, 2006
    Location:
    UK
    #1
    I'm by no means a computer newbie - although I am a new iPhone user.

    But what should have been straightforward update has killed my iPhone 3G wi-fi and bluetooth :(

    Wi-fi says 'No wi-fi'
    Bluetooth says 'unavailable'

    I have done a restore to factory, then restore from backup (twice)
    I've done a reset networj settings
    I've done a resttore to factory then 'setup as new phone'
    I've reset settings.

    I'm now on a full reset - it said it would take 2 hours.

    Any other advice? It's on O2 in the Uk - could I take the phone to the local Apple store for a fix?
     
  2. Phil A. Moderator

    Phil A.

    Staff Member

    Joined:
    Apr 2, 2006
    Location:
    Shropshire, UK
    #2
    Sounds like your phone is screwed :(
    About the only other possible thing you could try would be to do a restore from DFU mode (not the same as a normal restore). To kick off DFU mode, plug the Phone in and have iTunes running connected to the phone. Hold down the power and home buttons for approx 7 seconds (until screen goes blank), and let go of power button only (keep hold of home button).
    After about 10 seconds the phone will connect to iTunes but nothing will be on the phone screen (very important - if you see the connect to iTunes logo you're not in DFU mode). You can then try doing a restore.
    If that doesn't work, it could be a hardware fault, so your only other option would be to take it back to an Apple store :(
     
  3. Jowl thread starter macrumors 6502

    Joined:
    Apr 13, 2006
    Location:
    UK
    #3
    Okay, thanks for the advice.

    when it's finshed doing this, I'll have a go (in the morning!)

    Doesn't look like I'll get my bodyguard skin on tonight!
     
  4. Jowl thread starter macrumors 6502

    Joined:
    Apr 13, 2006
    Location:
    UK
    #4
    Tried a restore in DFU mode. Looks like I'm off to the Apple Store :(
     
  5. Jowl thread starter macrumors 6502

    Joined:
    Apr 13, 2006
    Location:
    UK
    #5
    Visited a Genuis, he 'confirmed' that it was a hardware fault and swapped it for a new one.

    Woo hoo!
     

Share This Page