2.1 message in Cydia?

Discussion in 'Jailbreaks and iOS Hacks' started by mdwsta4, Oct 29, 2008.

  1. mdwsta4 macrumors 65816

    Joined:
    Jul 23, 2007
    #1
    i currently have a 1st gen iphone that is unlocked/jailbroken and running 2.0.2. there are a few apps through the app store that i'd like to run, but they require 2.1 firmware. plus i wouldn't mind the genius feature.
    i know there's quickpwn to do this, but while visiting cydia last night i noticed a 'upgrading to 2.1, read this' link. it states that 2.1 will make my device become unjailbroken. that's only if i don't use pwnage 2.1, correct?

    i'm not really looking forward to downloading all the apps, redoing my background/icons/carrier logo and everything else again on the new firmware, but i've been putting it off long enough.

    can you not add the installer app via quickpwn? as much as i liked that app before, it seems useless and there are no apps in it any longer. or do you have to go the long way through pwnage?
     
  2. rotobadger macrumors 65816

    rotobadger

    Joined:
    Sep 18, 2007
    #2
    Unfortunately, when upgrading your firmware, you will lose your Jailbreak. You will have to re-Jailbreak if and re-install your JB apps if you want 2.1 on your iPhone. There are a couple of apps that will make a list of what you have installed but there is currently no actual backup for JB apps and settings.
     
  3. Chiny macrumors 6502

    Joined:
    Jan 28, 2008
    #3
    Their is a app in cydia called FWChanger, install it open it put this in ware it says fireware: 2.1(5F136) and for Builder just put fwchanger and hit set custom fireware that will solve your problem. TRUST ME!!!! Make sure u enter the info the the same way I posted it.....
     
  4. mdwsta4 thread starter macrumors 65816

    Joined:
    Jul 23, 2007
    #4
    wait, so from this i can upgrade the firmware from my phone?

     
  5. rotobadger macrumors 65816

    rotobadger

    Joined:
    Sep 18, 2007
    #5
    It worked for you? I tried it twice and ended up having to restore my phone twice. It killed my iPhone.

    OP: This app is supposed to trick applications into thinking your phone is on 2.1 (or whatever firmware you choose). It does NOT actually change your firmware.

    Again, it did not work for me.
     
  6. TheConfuzed1 macrumors 6502a

    Joined:
    Jun 4, 2003
    #6
    No offense, but you should never trust anyone that says, "Trust me."

    That goes double when the person saying it is anonymous.
     
  7. Chiny macrumors 6502

    Joined:
    Jan 28, 2008
    #7
    Look if u don't want to go threw the hassel of re-jb-ing ur phone the app works. Im running 2.0.1 and I used it to fake out itunes to update some app's that I have that the updates required 2.1 and it worked so its up to u.
     
  8. TheConfuzed1 macrumors 6502a

    Joined:
    Jun 4, 2003
    #8
    It makes more sense to me, to just have the right firmware.
     
  9. rotobadger macrumors 65816

    rotobadger

    Joined:
    Sep 18, 2007
    #9
    I agree. Why risk unstable apps and headaches just to aviod spending an hour or so upgrading and re-Jailbreaking?

    Also, using FWChanger does not mean all apps for 2.1 will work. Remember: FWChanger only changes what firmware is REPORTED. It does nothing else.
     
  10. mdwsta4 thread starter macrumors 65816

    Joined:
    Jul 23, 2007
    #10
    well out of the blue yesterday my phone stopped working. took it to the apple store and they gave me a replacement! :) so i ended up having to redo everything anyway. ah well. at least i'm on the most current version.
     
  11. rotobadger macrumors 65816

    rotobadger

    Joined:
    Sep 18, 2007
    #11
    Well, that made it easy! At least you don't have to worry about it now...
     

Share This Page