2,2 Firmware-Updated App Store Apps Wont Sync

Discussion in 'Jailbreaks and iOS Hacks' started by Enigmafan420, Dec 6, 2008.

  1. Enigmafan420 macrumors 6502a

    Enigmafan420

    Joined:
    Apr 18, 2008
    Location:
    Puget Sound, U.S.A.
    #1
    Ever since I went to 2.2, I can't "update" App Store Apps. I get an error message every time saying the update failed for an unknown reason.

    I have been getting around this by deleting the "old" version of the App and installing the new one. This, however, obviously leads to lost app data.

    Anyone else having this problem or know of a solution?

    Thanks!
     
  2. ajnicho macrumors 6502a

    Joined:
    Sep 24, 2008
    #2
    I've been getting the exact same problem. However my app data doesn't seem affected.
     
  3. Enigmafan420 thread starter macrumors 6502a

    Enigmafan420

    Joined:
    Apr 18, 2008
    Location:
    Puget Sound, U.S.A.
    #3
    I wonder why I am loosing App Data? Maybe I should restore a back-up after an application update?
     
  4. Mac?Daddy macrumors member

    Joined:
    Oct 8, 2008
    Location:
    Alberta
    #4
    I've been having the same problem with a few of my apps since the update, anyone know a solution?
     
  5. chrishch macrumors member

    Joined:
    Jan 26, 2007
    #5
    I hate me too messages, but me too!

    Any app updates can't sync from iTunes, and can't be installed directly on the iPhone. It's very annoying.

    There are certain apps that have data that I can't simply remove it and then re-sync it afterwards.

    Maybe this only affects jailbroken 2.2 units? I'm not sure, as mine was jailbroken using the Pwnage Tool.
     
  6. chu2chu3chuut macrumors newbie

    Joined:
    Dec 9, 2008
    #6
  7. Enigmafan420 thread starter macrumors 6502a

    Enigmafan420

    Joined:
    Apr 18, 2008
    Location:
    Puget Sound, U.S.A.
    #7
    Thank you-this did the trick!

    When I originally posted asking if there was a new mobileinstallation framework-I was told there was not and that 2.1 would work with 2.2 :confused:
     

Share This Page