2.3.1 update failed

Discussion in 'Apple TV and Home Theater' started by celica73, Mar 8, 2009.

  1. celica73 macrumors member

    Joined:
    Jan 12, 2009
    #1
    I can't seem to update to 2.3.1

    I'm running an ATV that has been upgraded to a 120GB hard drive and it works fine. System diagnostics report no errors.

    I tried a factory restore (which worked fine) but get the same error after trying to run the update. It seems to download just fine, but chokes when running the install. The status bar comes up, never moves and I get an error message after a few seconds.

    Any thoughts? Could my partitions be the wrong size? Any other thoughts? I've not seen anyone else complaining, so I don't think it's specific to the updated hard drive.

    I really don't want to restore the 40GB partition to try and do it again...

    Scott
     
  2. richyscot1 macrumors member

    Joined:
    Dec 8, 2008
    Location:
    Derby, UK
    #2
    Exactly the same problem????

    I've upgraded to a 250Gb hard drive, and have exactly the same problem??? I had to resurrect my 40Gb (original apple tv drive) drive, put it back into apple tv, perform the update. I then had to completely flatten my 250Gb hard drive (which contained 2.3) and start from scratch??? I have never had any problems with my drive upgrade.....all worked superbly and diagnostics claimed it was all functioning correctly??

    Anybody have any ideas??
     
  3. richardhunt macrumors regular

    Joined:
    Oct 2, 2007
    #3
    same thing happened to me. Upgraded from 40GB to 250GB. Factory restore worked to 1.0 with full capacity and then tried to update to 2.3.1. Downloaded the file correctly through the :apple:tv interface and then after downloading, it gave me the update failed message. I had to re-image the OSBoot partition from my old 40GB drive in order to get things going.
     
  4. Cave Man macrumors 604

    Cave Man

    #4
    If you can pull your hard drives, all you need to do is download the 2.3.1 updater, connect your ATV drive to your Mac, then restore to the OSBoot partition using the downloaded image with Disk Utility. Put it back together and you're set. Only takes about a minute to do the restore.
     
  5. celica73 thread starter macrumors member

    Joined:
    Jan 12, 2009
    #5
    Can I do it using ssh?

    If so, how about a hint on the commands (I'm not afraid to use ssh, just don't know how to do it myself).

    If I can't do it without opening the case, then I guess I'll do the restore option when I have some free time. Thanks for the tip!

    Scott
     
  6. celica73 thread starter macrumors member

    Joined:
    Jan 12, 2009
    #6
    Done. It worked fine. The restore kept failing until I went into the terminal and do a sudo rm of the boot.efi file on the OSBoot partition.

    At least it only takes a few minutes to pull the drive. The restore takes another couple of minutes.

    Scott
     

Share This Page