2.4 20" iMac w/ external HD problems

Discussion in 'iMac' started by killerrobot, Oct 10, 2007.

  1. killerrobot macrumors 68020

    killerrobot

    Joined:
    Jun 7, 2007
    Location:
    127.0.0.1
    #1
    I just bought a new iMac -stock config- and it cannot mount my 300 GB Maxtor One Touch External HD (yes it has its own power source).
    I had the same problem with my 2.33 MBP when I installed the 10.4.10 update and after several months of not having access to my external I found this thread which actually had a solution that worked and my external and MBP became happy friends again.
    I've tried the same thing on my iMac only to realize that it won't let me change any of the files because it's post 10.4.9. When that failed, I searched and found this idea http://www.macosxhints.com/article.php?story=20070628092633507
    but it and everything else suggested doesn't work either.
    Frustrated I called Applecare, and after telling me to do the most obvious things which I started off doing (DiskUtility -pointless because it doesn't mount-, boot from install disk - pointless because it doesn't mount, etc.) and after 45 minutes of them saying "well, um, oh, let me ask my supervisor" they ended up telling me I'd have to take it to the Genius Bar.
    At the moment, my only solution is to share it through my MBP, but when the MBP is being used elsewhere, there is no way to do it. I'd rather just return my 2 day old iMac than hand over my external (which I know they will wipe because they'll blame it as the culprit of everything) and my iMac for a problem they won't be able to solve because I think this goes way over the Genius' heads.
    So with all that said, can anyone on this forum (madjew I want at least a funny reply) help before I return my iMac and never buy another Mac for the rest of my life.:):confused::eek:

    Thanks in advance.
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Okay. A nose walked into a bar and asked for a drink. The barman turned to him and said "no, clearly you're off your face".

    Sorry, that was pretty bad. Disk Utility can recognise unmounted drives. The fact the disk isn't showing up at all in Disk Utility means it's not even recognised, let alone mounted, which is a little worrying. I know you've been asked the obvious questions, but I have a few more if you'd just humour me. Sorry if we go over old ground.


    • Do you have any other peripherals plugged into the iMac?
    • Does it spin up when it's connected to your iMac, as if it recognises there's a computer plugged in? Or does it simply not react when connected?
    • If you have Boot Camp, have you tried it in Windows?
     
  3. nissan.gtp macrumors 6502

    Joined:
    Aug 22, 2007
    Location:
    Virginia
    #3
    I had a similar problem with my iMac and an external drive

    they this:

    reset power management -- shutdown computer, unplug ALL CABLES, wait 15 seconds or more, plug power cable back in, then kbd and mouse. boot.

    reseting PRAM is a good idea as well
     
  4. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #4
    Funny, I've have the same machine.

    And I haven't had a problem with the Maxtor 320GB or the cheap CompUSA external combo drive case.
     
  5. killerrobot thread starter macrumors 68020

    killerrobot

    Joined:
    Jun 7, 2007
    Location:
    127.0.0.1
    #5
    @Madjew
    Thanks for the joke. Now some replies,

    • have the external, kboard andmouse plugged in
    • yes it completely spins up (if its plugged in while restarting, the iMac tries to use it as the boot drive, but will never see it again)
    • No, staying away from bootcamp, plus its HFS+ formatted, but my MBP has no problems mounting it


    @nissan
    Thanks for the ideas as well, I've tried doing them all several times as well.

    @Sun Baked
    Does you have a One Touch USB 2.0, a One Touch II, One Touch III or One Touch IV?

    As of this moment I just have mounted it on the MBP, and will just transfer files over the home network.
    I believe it has to do with the .kext files still - I hope Apple fixes it sometime-I filed a bug report so we'll see if anything comes of it, but I doubt it since they are medal to the pedal on Leopard now.
    Any other suggestions would be appreciated.
     
  6. jnash macrumors regular

    Joined:
    Apr 26, 2007
    Location:
    Michigan
    #6
    is the drive in ntfs format? If so thats your problem when I was new to mac's and I had an external 500 GIG Lacie drive it would see the drive but I couldnt see crap on there after going threw all the crap you are I backed up the data to another drive formated it to fat32 and booyahh it worked
     
  7. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #7
    No, the OP has said the drive is HFS+ formatted. besides, OS X can still mount and read from an NTFS drive (I do it all the time). You just can't write to NTFS volumes.
     
  8. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #8
    Just a plain jane Maxtor 320GB Personal Storage Device with USB2.

    But neither that or the cheap case have cause any issues, both are always connected, sleep when possible, and turned off when not in use.
     
  9. jnash macrumors regular

    Joined:
    Apr 26, 2007
    Location:
    Michigan
    #9
    Hmm doesnt work for me and my 500 GIG NTFS Lacie.. pm me with any tips please ;)
     

Share This Page