2.8ghz MBP Quake 4

Discussion in 'Mac and PC Games' started by zao8350, Jul 2, 2009.

  1. zao8350 macrumors regular

    Joined:
    Jul 2, 2009
    #1
    so i have quake 4 and a brand new 15.4" MBP. its the 2.8ghz with the extra 512mb video card. i assumed that it would be able to play any game on the highest settings pretty much flawlessly, but for some reason quake 4 randomly gets laggy or jumpy. once or twice it just stopped, then continued after 10 seconds. is it just that intense or is there something i can do to make it run better? thanks for your time
     
  2. voyagerd macrumors 65816

    voyagerd

    Joined:
    Jun 30, 2002
    Location:
    Rancho Cordova, CA
    #2
    Do you have the 1.4.2 patch? Quake 4 runs great on my 2.66GHz MBP and even ran decently on my 1.8GHz G5.
     
  3. zao8350 thread starter macrumors regular

    Joined:
    Jul 2, 2009
    #3
    yes i do. idk what the problem is. i may back up my saved games and reinstall or something
     
  4. voyagerd macrumors 65816

    voyagerd

    Joined:
    Jun 30, 2002
    Location:
    Rancho Cordova, CA
    #4
    I'm running it at 1680x1050 on an external display. Make sure you have it set to the native resolution of your display, 1440x900. I have it set to High Quality. I don't have multisampling on. Also make sure the multiprocessor option in advanced options is turned on. Make sure you have it plugged in to power when you play.
     
  5. Kat King123 macrumors regular

    Kat King123

    Joined:
    Jan 3, 2009
    #5
    im on max settings and native resolution on my mac(see sig) and it runs great no lag whatsoever
     
  6. whooleytoo macrumors 603

    whooleytoo

    Joined:
    Aug 2, 2002
    Location:
    Cork, Ireland.
    #6
    If it's generally ok, put periodically lags badly at random (not just when you enter a complex scene in the game), it sounds more like disk access.

    Either you're running low on RAM and the game is starting to read from VM on disk, or (more likely) another process is launching/processing in the background and causing Quake to stutter. It could be something like the Spotlight indexer kicking in? Or could you have your Mac set for the disk to sleep when possible? If so, that could cause it.
     
  7. RiotGaming macrumors newbie

    Joined:
    Jul 9, 2009
    #7
    Even the 3rd Gen Macbook GMA950 can run Quake 4 without any lag... I'm not sure what's happening to your MBP.
     
  8. zao8350 thread starter macrumors regular

    Joined:
    Jul 2, 2009
    #8
    i dont think its any of that. apparently you can make the mbp run off the beefier video card so i did that. the only time it lagged was when the autosave hit in, which was mildly annoying and the game jsut paused for a half sec.
     

Share This Page