2 Airport Expresses and a Linksys WRT54G problems

Discussion in 'Mac Accessories' started by aarongibson, Jul 10, 2008.

  1. aarongibson macrumors newbie

    Joined:
    Feb 23, 2006
    #1
    Hi,

    I have a Linksys WRT54G Wireless Router. I am also trying to connect 2 Airport Express units in different locations in the house to extend the network. The problem is neither of them show up in the Airport Utility when it is opened and a rescan yields nothing. They both have green lights and seem to be working. They are both set up in extend a wireless network mode as I couldn't get them both to be recognisable for a WDS network.

    They were both set up via ethernet from my PowerBook and have been reset. The Linksys is dishing out IPs via DHCP and both of them show up with an IP address and their MAC addresses in the device table. What am I doing wrong?? One is a UK Express, and the other is a US Express and I am currently in Cyprus. I just want them to run wirelessly and extend the range of the Linksys.

    Also, I can only re-detect them when I plug an ethernet cable back in.

    Lastly, I am going to be plugging in another Linksys WAP to extend further. Any help would be greatly received.

    Aaron
     
  2. Tom Foolery macrumors regular

    Joined:
    Oct 16, 2007
    Location:
    Toronto, Canada
    #2
    your best bet is to set them up one at a time using a cable which will probably eliminate the not showing up thing. i have one working with my wrt54g and i'm trying to get it to work with my wrt300n. connect with ethernet if you can if not make sure your are in close range to your router. for this setup you will need to select 'participate in WDS'

    go into the internet tab
    Make sure you set the ip manually to 192.168.1.# (# represents any number between 2 and 200) use subnet: 255.255.255.0 and router address: 192.168.1.1 and dns 4.2.2.2/4.2.2.3. after you've entered those numbers switch back to DHCP the numbers should stay the same. also make sure you've got connection sharing set to off (bridge mode).

    2 more steps.

    http://192.168.1.1
    go there and click on the status tab, then click on the WIRELESS subtab (it's important that is be thes tab and not the other 2). copy the MAC exactly. now go back to airport util and go into airport then click WDS subtab. my setup is 'WDS Mode: WDS Main' and i have entered my MAC address in the WDS remote catagory however you may want to play around with this because your setup is different. read the wikipedia on WDS and decide which is right for you. but try my way first to save some time.

    Finally go to the wireless subtab and select a 'wireless security: WEP'. type a 13 character password, now go to base station menu from the task bar and select equivalent network password it will pop up with a 26 character password, copy that password. now once again go back to the linksys setup and click the WIRELESS tab then WIRELESS SECURITY subtab. set the security more to WEP and set WEP encryption to 128 bit. now paste the password and save the settings.

    now go back to the router and change the network name to the exact name of the network you want to join. now click update and see if you did it right

    it might come back and say wds error but don't worry if you set it up properly the light should turn green and you'll be good to go. repeat for the second AE enjoy life.

    please let me know how this works out for you, and just ask if you have any questions. and people in the future using this as a reference please feel free to private message me with questions.

    note: i used leopard 10.3 and airport util 5.3.2
     
  3. aarongibson thread starter macrumors newbie

    Joined:
    Feb 23, 2006
    #3
    Thanks Tomfoolery.

    I haven't tried this out yet but I will follow your instructions, they seem to make good sense. Thank you for your reply!

    Aaron
     
  4. spaceballl macrumors 68030

    spaceballl

    Joined:
    Nov 2, 2003
    Location:
    San Francisco, CA
    #4
    I used to have an airport express working with my wrt54g. I think it's important that you set it up to extend a WDS network. It will take some configuration, but if you do some googling, there are guides out there on how to get it all setup.
     

Share This Page