2 atv's- 1 logs into itunes, 1 doesn't (anymore)

Discussion in 'Apple TV and Home Theater' started by needthephone, Oct 30, 2011.

  1. needthephone macrumors 6502a

    Joined:
    Apr 4, 2006
    Location:
    sydney
    #1
    I'm frustrated with my main apple TV (2) which is connected to my living room TV. After the latest update no matter what I do it say's I'm putting in the wrong password and/or account name for itunes sharing and to rent movies from itunes.

    I rebooted twice, turned off my imac, tured off itunes, re set my router, reset my broadband.

    All I can do is air play from my ipad/iphone but the amin function of the atv is broken.

    The apple TV 2 upstairs also was updated but it logs into itunes Ok.

    Anyone any ideas- This apple TV is FLAKY to say the least, so temperemental so UN Apple.
     
  2. lazer310 macrumors member

    Joined:
    Jun 9, 2010
    #2
    Had something similar with a friends second Apple TV. Turned out the Apple TVs counted towards the 5 devices allowed to connect to iTunes.
    Try deauthorizing the Apple TV that works, then try the one that doesn't.

    When I fixed my friends, I did the reset all devices in his itunes account, and set up everything fresh, and it worked.
     
  3. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #3
    Assuming You Have Updated

    And there are 2 of the darn things.........Do as posted.

    I have 3 And they al work fine, but didn't until the updates were applied....Icloud? God but buggy!
     
  4. testerdennis macrumors member

    Joined:
    Aug 7, 2011
    #4
    This may sound strange, what remote are you using to put in your user name and password. When I updated I ran into this problem when trying to put my user name and password in. I was trying to input using the remote from my iPhone and I tried 5 times did not let me in. I then grabbed the Apple TV2 remote to input my user name and password and holy crap it worked. This happened on 2 of my Apple TV'S. I can't tell you why but thats what happened to me.
     
  5. needthephone thread starter macrumors 6502a

    Joined:
    Apr 4, 2006
    Location:
    sydney
    #5
    Thanks. Maybe you could be right. We have 2 iPhones, an iPad, 2 iMacs and. 2 atv's so more than 5.

    I am using the remote not iPhone as I can't pair the iPhone with the atv as it doesn't see it- apart from air tunes.

    I love the atv but it is buggy and all was fine before the cloud and these last updates
     
  6. slothrob macrumors 6502

    Joined:
    Jun 12, 2007
    #6
    I had something similar happen to me after a power outage. It turned out that the time was set wrong on the aTV2, and it couldn't reset because it couldn't connect to the web. I set the time and then it accepted the ID.
     

Share This Page