2 MBPs and a DLink wireless router

Discussion in 'MacBook Pro' started by mikeottinger, Dec 23, 2008.

  1. mikeottinger macrumors newbie

    Joined:
    Dec 23, 2008
    #1
    Hi All,

    My personal MacBookPro is a model 1,1 from late 2006. It supports 802.11g and I almost never have problems with wireless networks. My work laptop is a model 4,1 which supports 802.11n. It as well never has issues with wireless networks. My in-laws have a Dlink wireless router that does not like my personal mac, or I should say my personal mac doesn't like it. What seems to happen is I get an incredibly slow connection speed. For instance certain media-rich sites never get loaded, everything is sluggish, even if I'm sitting right next to the router. My work laptop on the other hand works like a charm, no problems at all. I'm curious if anyone knows if the difference in 802.11 protocol support is contributing to this? My wife's mac also supports 802.11n and she seems to have issues too. Unfortunately I can't seem to log into the admin page of this router, it's probably configured to use a non-default IP, I'm trying to get in touch with my in-law's computer guy on that. Any ideas would be greatly appreciated, this is little bit of a mystery.
     
  2. Padaung macrumors 6502

    Padaung

    Joined:
    Jan 22, 2007
    Location:
    UK
    #2
    Yeah, I'm having issues with a new D-Link router too, also of the 'n' protocol. With me a web page load just stalls for no reason. I need to turn of the airport on my Macbook and then turn it back on and the page load kicks back into life. The old router ('g' spec) did not cause this problem.

    To find the IP of the router try out the app called IP Scanner, which can be found here: http://10base-t.com/
     
  3. mikeottinger thread starter macrumors newbie

    Joined:
    Dec 23, 2008
    #3
    thanks for the link to IPScanner, that's a useful tool aside from this issue. I actually found out the router is a G router, not an N, so both laptops should theoretically work fine.
     
  4. cg165 macrumors regular

    Joined:
    Jun 24, 2008
    #4
    I had this exact issue on my unibody MBP. The problem was resolved with a software update from apple. I think they sent out updates specifically for these machines that fixed it, or it was in 10.5.6 ...make sure you are up to date through software update. Mine seems to be fixed now though, and maybe they have an update for the other wireless cards also or are working on one. Check software update, the apple website and post about it on the forums.
     
  5. mikeottinger thread starter macrumors newbie

    Joined:
    Dec 23, 2008
    #5
    thanks for the reply, I'm actually running tiger (10.4.11) and unfortunately this has been a long standing problem spanning many versions of my OS that's been driving me insane and want to get to the bottom of. So far I've tested 3 laptops, 2 MBPs with the problems described in my original post, in addition I've tried a MacBook also running tiger but supporting 802.11n, it is having the same problems. My work MBP that doesn't have problems is running Leopard, perhaps it is an OS issue? Thanks again.
     
  6. puppyraiser macrumors newbie

    Joined:
    May 22, 2009
    #6
    anyone figure out how to fix this? i've got a dlink router and a macbook, and it routinely does the same stall the previous poster mentioned. i have to turn airport off and back on again to get it loading again. my husband has a HP, and it doesn't do this for him... i've tried resetting it multiple times, with no luck... what else can i try? making it unsecure? new router?
     
  7. capriseyhaze macrumors regular

    capriseyhaze

    Joined:
    Mar 3, 2009
    Location:
    florida
    #7
    what i did was contacted dlink and i had to change around alot of router information on the dlink site. that has worked for me. dlinks by default dont work with macs so you have to configure them with the right channels and all that. so give them a call and they will help you.
     
  8. puppyraiser macrumors newbie

    Joined:
    May 22, 2009
    #8
    thanks for the advice, that's what i'll do next if my current fix doesn't work. i found another thread about general wireless problems and one poster set his beacon interval lower for his dlink... so far that has worked all day today, and i'm not being kicked off any more. (it was happening every 15 mins or so.)
     

Share This Page