2 Problems: iPhoto doesn't see iPhone pics AND iTunes doesn't have a 'backup' button

Discussion in 'iPhone Tips, Help and Troubleshooting' started by coledog, Jun 29, 2009.

  1. coledog macrumors 6502a

    coledog

    Joined:
    Nov 14, 2006
    Location:
    Roanoke, VA
    #1
    PROBLEM ONE:
    I have about 18 pics on my phone and I would like them on my Mac.

    When I connect the phone iPhoto sees the iPhone supposedly under devices, but when I look at it there are only 3 image place holders with no images showing. When I ask to import the pics it says everything is unreadable.

    Also when I disconnect the phone it says in iPhoto that it's still connected with only an unmount option.

    I have under occasion gotten the phone to show up separately and download the pics but I don't know what I do to make it work.

    Things I've tried:
    Restarting phone
    Restarting iPhoto
    Restarting the Mac
    Grabbing the images through Image Capture, same result

    I'm not sure what else to do or try...any help?


    PROBLEM 2:
    I noticed this first when I was trying to backup my 3G but thought nothing of it. Now I notice that the 'backup' option for my iPhone 3GS also isn't in the menu on iTunes when I right click on the phone.

    Any suggestions?
     
  2. gasport macrumors 6502

    gasport

    Joined:
    Mar 10, 2007
    #2
    I encountered a similar problem yesterday. I have 26 items in my camera roll and 2 of them are videos taken with the new 3GS. I emailed both videos and downloaded to You Tube from within the iPhone. I wanted to get the uncompressed version of the videos and first tried iPhoto and experienced a similar problem. The placeholders were there but no thumbnail although there were 2 little cameras indicating that 2 were videos. When I tried to download to iPhoto I got an error. I then tried Image Capture and it too saw the 26 items and properly identified the 2 videos even providing details. I downloaded to the default folders and even though it appeared to download the files (no error was received) there was nothing in the folder.

    I had no problem downloading from my older 3G. I have no clue wheter this is a problem with the iPhone or OS X 10.5.7. I was eventually able to get the video off the iPhone using a third party application and run both in Quicktime. I know that the files on the iPhone are not corrupted as I was able to view them.

    I will be giving Apple a call today as this is really frustrating...:mad:
     
  3. coledog thread starter macrumors 6502a

    coledog

    Joined:
    Nov 14, 2006
    Location:
    Roanoke, VA
    #3
    Exactly the same issue as mine, please let me know what Apple says!
     
  4. gasport macrumors 6502

    gasport

    Joined:
    Mar 10, 2007
    #4
    I read some other posts and am trying a few things first.

    I just attached the iPhone to my MacBook. It was not recognized by either iPhoto or Image Capture. I ran Image Capture and it did pick up the iPhone. I clicked download all and it immediately downloaded all the file and place them in the appropriate folder.

    So the problem is my iMac and some of the posts have addressed this and I will try them first to see what gives. It has to do with the Library or Cache from my previous iPhone and how I updated the new one I beleive.:rolleyes:

    Update,

    I removed the iPhoto plist from the Library to the desktop. I then attached the iPhone and immediately iPhoto opened and recognized the iPhone. The thumbnails of the files were now present and downloading worked like a charm. I then tried it in Image Capture and had the same positive results.

    So, for me it was a corrupt plist file on the MAC I used to activate and update the new iPhone. Hope you have the same results.
     

Share This Page