2 Problems: Ipod Nano Causes Kernal Panic & USB Ports not Registering as 2.0...

Discussion in 'macOS' started by therapistfinder, Nov 15, 2008.

  1. therapistfinder macrumors member

    Joined:
    Oct 8, 2008
    #1
    I bought the Late 2008 MBP and the USB ports are not registering as 2.0. I have confirmed that it is indeed running at 1.0 speeds through synching my ipod touch through itunes as well as through transferring files from an external hard drive. The transfer speed averages around 1-1.5 mb/sec, which is in line with USB 1.0 speeds.

    I've lived with it for a few weeks, but I just got a new ipod nano today and whenever I connect it to my MBP, the screen turns gray and I immediately get this message:

    "You need to restart your computer. Hold down the power button for several seconds or press the restart button."

    I've tried resetting the SMC but to no avail. It hasn't escaped from my attention the possibility that the two problems are interrelated. I haven't been able to find OS X drivers for the USB ports, so right now the only option that I know of is to reinstall leopard. Does anyone know of a simpler solution that wouldn't require a complete reinstall of the OS?

    EDIT: Just realized that I can't spell "Kernel"....
     
  2. TuffLuffJimmy macrumors G3

    TuffLuffJimmy

    Joined:
    Apr 6, 2007
    Location:
    Portland, OR
    #2
    You can try repairing permissions *although this doesn't sound like a permissions issue*.

    It might just be a faulty Logic board, so your best bet would be to take it to an Apple Store and get a replacement.
     
  3. therapistfinder thread starter macrumors member

    Joined:
    Oct 8, 2008
    #3
    Just tried repairing permissions for the hell of it, didn't fix anything.

    Here's the report: Hope there's someone out there that can interpret the problem from this....

    System Configuration:
    Model: MacBookPro5,1, BootROM MBP51.0073.B02, 2 processors, Intel Core 2 Duo, 2.4 GHz, 2 GB
    Graphics: kHW_NVidiaGeForce9600MGTItem, NVIDIA GeForce 9600M GT, spdisplays_pcie_device, 256 MB
    Graphics: kHW_NVidiaGeForce9400MItem, NVIDIA GeForce 9400M, sppci_pci_device, 256 MB
    Memory Module: BANK 0/DIMM0, 1 GB, DDR3, 1067 MHz
    Memory Module: BANK 0/DIMM1, 1 GB, DDR3, 1067 MHz
    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8D), Broadcom BCM43xx 1.0 (5.10.38.9)
    Bluetooth: Version 2.1.2f8, 2 service, 1 devices, 1 incoming serial ports
    Network Service: AirPort, AirPort, en1
    Serial ATA Device: Hitachi HTS543225L9SA02, 232.89 GB
    Serial ATA Device: MATSHITADVD-R UJ-868
    USB Device: Built-in iSight, (null) mA
    USB Device: Apple Internal Keyboard / Trackpad, (null) mA
    USB Device: IR Receiver, (null) mA
    USB Device: BCM2045B2, (null) mA
    USB Device: Bluetooth USB Host Controller, (null) mA


    Problem Details:
    Sat Nov 15 22:07:48 2008
    panic(cpu 0 caller 0x003EB5B6): "IOUSBDevice::_RESERVEDIOUSBDevice8 called\n"@/SourceCache/xnu/xnu-1228.8.30/libkern/c++/OSMetaClass.cpp:816
    Backtrace (CPU 0), Frame : Return Address (4 potential args on stack)
    0x2fea7a68 : 0x12b4c9 (0x45aaac 0x2fea7a9c 0x1335ba 0x0)
    0x2fea7ab8 : 0x3eb5b6 (0x49bc5c 0x5b4280 0x5b4280 0x8)
    0x2fea7ad8 : 0x5a54d4 (0x5bc118 0x8 0x2fea7b08 0x3ecac9)
    0x2fea7af8 : 0x3c73fb56 (0x455fb00 0x2fea7b1c 0x2fea7b28 0x3f0093)
    0x2fea7b28 : 0x3c740a0a (0x4c58a00 0x3c745ad0 0x43a95c0 0x0)
    0x2fea7b78 : 0x412202 (0x4c58a00 0x4b59100 0x1 0x3ec9d0)
    0x2fea7bd8 : 0x414097 (0x4b59100 0x4c58a00 0x48aebc0 0x48ae540)
    0x2fea7c58 : 0x4138fb (0x4b59100 0x47fcd00 0x0 0x1)
    0x2fea7ca8 : 0x414afc (0x4b59100 0x2 0x0 0x0)
    0x2fea7ce8 : 0x40e12e (0x4b59100 0x2 0x0 0x4b59100)
    0x2fea7d28 : 0x5a3c75 (0x4b59100 0x2 0x4 0x0)
    0x2fea7da8 : 0x7dbe3c (0x455fb00 0x4a05c80 0x1 0x1)
    0x2fea7dc8 : 0x7db886 (0x4a05c80 0x1 0x1 0x0)
    0x2fea7e18 : 0x7db3f5 (0x4a05c80 0x5bc118 0x431ad40 0x10001)
    0x2fea7e48 : 0x412202 (0x4a05c80 0x455fb00 0x1 0x3ec9d0)
    0x2fea7ea8 : 0x414097 (0x455fb00 0x4a05c80 0x48b5c20 0x48b5c80)
    Backtrace continues...
    Kernel loadable modules in backtrace (with dependencies):
    com.apple.iokit.IOUSBMassStorageClass(2.0.3)@0x3c73e000->0x3c747fff
    dependency: com.apple.iokit.IOSCSIArchitectureModelFamily(2.0.5)@0x618000
    dependency: com.apple.iokit.IOUSBFamily(3.1.5)@0x595000
    dependency: com.apple.iokit.IOStorageFamily(1.5.4)@0x631000
    com.apple.driver.AppleUSBComposite(3.0.0)@0x7da000->0x7ddfff
    dependency: com.apple.iokit.IOUSBFamily(3.1.5)@0x595000
    com.apple.iokit.IOUSBFamily(3.1.5)@0x595000->0x5bcfff

    BSD process name corresponding to current thread: kernel_task

    Mac OS version:
    9F2114

    Kernel version:
    Darwin Kernel Version 9.5.1: Fri Sep 19 16:19:24 PDT 2008; root:xnu-1228.8.30~1/RELEASE_I386
    System model name: MacBookPro5,1 (Mac-F42D86C8)
     
  4. Auburn macrumors newbie

    Joined:
    Nov 24, 2008
    #4
    Same panic on Late '08 MacBook with USB floppy.

    USB2 works fine, but plugging in a USB floppy drive locks the MacBook solid with the same kernel panic ...

    panic(cpu 1 caller 0x003EB5B6): "IOUSBDevice::_RESERVEDIOUSBDevice8 called\n"@/SourceCache/xnu/xnu-1228.8.30/libkern/c++/OSMetaClass.cpp:816
    Backtrace (CPU 1), Frame : Return Address (4 potential args on stack)
    0x29ca7a68 : 0x12b4c9 (0x45aaac 0x29ca7a9c 0x1335ba 0x0)
    0x29ca7ab8 : 0x3eb5b6 (0x49bc5c 0x2fe88280 0x2fe88280 0x8)*


    Does anyone know if xnu-1228.8.30 has been released yet? The latest I can find is xnu-1228.7.58.tar.gz (17-Sep-2008 17:04) - it'd be nice to track down where the panic's coming from.
     
  5. ltldrummerboy macrumors 68000

    ltldrummerboy

    Joined:
    Oct 15, 2007
    #5
    As already stated by TuffLuffJimmy, this sounds like a hardware issue. Is there an Apple store near you? I would definitely return it.
     
  6. Auburn macrumors newbie

    Joined:
    Nov 24, 2008
    #6
    Have you tried booting from the Mac OS X Install DVD?

    Looking at your system profile output, there's a couple of things that seem slightly odd:

    USB Device: Built-in iSight, (null) mA
    USB Device: Apple Internal Keyboard / Trackpad, (null) mA
    USB Device: IR Receiver, (null) mA
    USB Device: BCM2045B2, (null) mA
    USB Device: Bluetooth USB Host Controller, (null) mA


    I'd exect USB devices to be showing some current values e.g.

    Built-in iSight:
    Current Available (mA): 500
    Current Required (mA): 500


    Another thing that looks odd is the version of your IOUSBFamily:

    dependency: com.apple.iokit.IOUSBFamily(3.1.5)@0x595000

    The version of IOUSBFamily that ships with the Late '08 DVD is 3.2.0, and I'd have thought that system update would have updated it to 3.2.2 - so it looks like your USB drivers may be older than the ones that should have shipped with the Mac.

    It might be worth confirming the version with System Profiler - it'll show you in Software->Extensions->IOUSBFamily.

    If it's older than 3.2.0, then try booting off the Mac OS X installer DVD and use System Profiler from the Utilities menu to confirm (a) what version of IOUSBFamily you're running, and (b) if any the current rating (mA) of the USB devices are shown.
     

Share This Page