Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

2-sided printing option is not working anymore

mason.smith1975

macrumors member
Original poster
Jun 2, 2012
71
43
Hi all,

I'm using the Epson Workforce 635 printer for a long time and everything works fine. Yesterday Apple updated the driver and the two-sided option is now disabled. I've tried uninstalling the printer and installed it again but the two-sided option is still greyed. Anyone can help me with this please? Thank you very much.

 

colodane

macrumors 6502a
Nov 11, 2012
841
282
Colorado
I have same problem on my Workforce 845.

It used to print in duplex just fine, but now not at all.

Yes, in the "Layout" section there is a separate selection box for "two sided printing". But as the OP pointed out, the selection is grayed out and cannot be used.
 
Comment

sleek881

macrumors regular
Aug 6, 2010
113
3
Sunshine Coast, Australia
Double-sided printing is not done Layout section.

 
Comment

chiarnia

macrumors newbie
Mar 1, 2015
2
0
it doesn't show

in my case it doesn't show this option!

Could anyone help me?
 

Attachments

  • Schermata 2015-03-01 alle 17.40.51.png
    Schermata 2015-03-01 alle 17.40.51.png
    97.3 KB · Views: 519
Comment

chiarnia

macrumors newbie
Mar 1, 2015
2
0
And as has been said, the two-sided box is grayed out...
 

Attachments

  • Schermata 2015-03-01 alle 17.44.28.png
    Schermata 2015-03-01 alle 17.44.28.png
    89.3 KB · Views: 417
Comment

curmudgeon1941

macrumors newbie
Oct 1, 2015
1
0
And as has been said, the two-sided box is grayed out...

I'm using a WF-3640. Using OpenOffice, click print. On the print menu, click the bar that identifies the app, in my case OpenOffice. A drop-down appears and at the bottom is the 2-sided print option. Click on it and select the binding option. Click print. I figured it out by trial and error.

I'm assuming it will be similar in other apps.
 
Comment

lisabean

macrumors newbie
Jun 5, 2017
1
0
I was having the same issue on my WorkForce 3620. The 2 sided box was greyed out. I went into preferences and selected the Epson as my default printer (I had another selected) and viola! The two sided print option came on.
 
Comment

F Wenzel

macrumors newbie
Jun 12, 2017
1
0
Is this an Apple problem or an EPSON problem? Why is it the the updates that are to correct an obscure problem causes real problems.
 
Comment

mmomega

macrumors demi-god
Dec 30, 2009
3,644
1,820
DFW, TX
When you reinstalled which driver did you choose. AirPrint or the Epson series driver.

I've had issues with various different models of printers where some options wouldn't work under the AirPrint driver but would under their own driver package.
 
Comment

colodane

macrumors 6502a
Nov 11, 2012
841
282
Colorado
After working perfectly for several years, the two-sided printing option is now again "grayed out" on my Espon 845.

Anyone else seen this lately? If so, how did you fix it?

Thanks
 
Comment

ATC

macrumors 65816
Apr 25, 2008
1,164
368
Canada
FWIW, I have a Canon MX870 and I'm also seeing the same thing since upgrading to High Sierra. It seems Canon (and probably others) have relegated driver support to Apple - there are no more driver downloads for my MX870 from Canon for High Sierra. And the Apple-provided driver seems to have broken two-sided printing - well almost.

The two-sided setting is greyed out and the Duplex Printing tab is gone when printing from Safari, Pages, Preview etc... but for some strange reason when I'm in MS Word 2016 for mac (using the same Canon driver from Apple) it shows the Duplex printing tab. After contacting Canon support, the rep made me create a print preset through MS Word and call it Double-sided (Duplex printing enabled) and that preset is available for other apps so I can now print double-sided again.

It's still odd that Apple's High Sierra printer drivers have essentially hidden/removed the duplex printing feature from many apps, including most of Apple's own.
 
Comment

Rippeddisc

macrumors newbie
Oct 14, 2011
10
0
Just an update to this....same issue with my printer; wf2760 + high sierra. Tried opening up Word, turning on 2-sided, but the duplex was still greyed out under layout. From the duplex settings (turned on), created a preset and then used that preset when printing from preview. Worked. Pretty damn frustrating to have that ridiculous of a work around.
 
Comment

Expobill

Suspended
May 30, 2018
1,424
927
but that works in preview?
have you tried that "pages"?
i might have to 2 page(doubt side) print but in color, which I'm delaying.
that is frustrating!

Highest sierra hated printing through my 2016 canon scanner printer.

welcome to 2018 were no one prints anymore, so why develop functions?
 
Comment

DCWinMTIDA

macrumors newbie
Jan 9, 2019
1
0
I had the same problem (MacOS 10.14.2). New MacBook Pro mid-2018 to which I migrated from a mid-2011 iMac. I had to delete the printer (Epson Artisan 835) and then re-add it to get the printer working at all. I could not set Two-Sided printing and save it in a preset as was configured on the iMac. In the Print dialog, the Two-Sided option in Layout is greyed-out.

However, I did try setting a preset in MS Word's print dialog as was suggested above, and that seems to have worked, as the preset now shows up and works when printing from Preview and Safari.

Thank you to the person(s) who published that trick.
 
Comment

doughemi

macrumors newbie
May 22, 2006
9
2
I have encountered this with my Epson WF7610. Unfortunately, I do not have MS Word, so that trick is not available. I tried @DCWinMTIDA 's sequence, which only changed my print dialog to remove the 2-sided printing checkbox which used to be there. MacOS 10.13.6 on an iMac, and it also fails on my wife's MacMini, also running 10.13.6.

Anyone have a workaround that doesn't involve Word?
 
Comment

washotmail

macrumors newbie
Jul 28, 2020
1
0
A year later, still the same issues. In this case a Mac (Catalina 10.15.5) printing on a Canon MF743C with drivers installed from Canon, not Apple. Same issue with greyed out two sided printing, looked through all the options. I deleted the printer from the mac Printers & Scanners and set it up through Google Cloud Print. I could then choose the printer in my PDF viewer and the duplex printing options showed up.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.