2 TB WD Passport Pro "not ejected properly"

Discussion in 'MacBook Pro' started by GSPice, May 1, 2014.

  1. GSPice, May 1, 2014
    Last edited: May 1, 2014

    GSPice macrumors 68000

    GSPice

    Joined:
    Nov 24, 2008
    #1
    So I ordered a 2 TB Western Digital Passport Pro, configured as RAID 0 (default). Here's the story. I'm hoping someone can chime in, because Western Digital Level 2 support hasn't resolved it yet.

    Background:

    Apr. 15: New out of the box, configured drive as RAID 0 on my sig machine (10.9.2).

    Apr. 15: Transferred 400+GB file to the drive, 300+MB/s transfer rate at times. Unplugged drive until..

    Apr. 21: Connected drive, not using it, but within minutes receive the "don't eject drives without dismounting" error. Worried, thought "did it go to sleep and dismount on it's own?"

    Reconnected, no problem. Within another several minutes, same thing. Could not reconnect/mount this time. Looked at WD Drive Config utility, and says that the drive 2 stripe failed. Nice. Had passed all diagnostic tests before.

    Erased both drives with Mac's disk utility, and used the WD Drive Config utility to setup as RAID 0 again.

    Restored lost data via Time Machine (epic win)

    Apr. 23: Worked for a few hours in FCP, backed up everything before going to bed.

    Apr. 24: Opened notebook to find drive had dismounted from stripe failure again. Created RMA with Western Digital.

    Western Digital says I'll get a replacement drive within 3-5 business days. At this point, if I set this one up and get another failure within the 3-year warranty period, my confidence with this drive will be a bit shaken.

    Apr. 29 Received new drive, same problem.

    Apr. 30 Level 1 support tells me to check the sleep timer on the WD drive utility. I go to the utility, the feature isn't there - tech is confused. A few minutes later I look under the release notes, and the sleep timer is only on "supported drives." I don't have a problem with that, but the tech being unaware of that didn't inspire any confidence.

    Level 2 support says I'm the first to call regarding this drive (not altogether surprising, seeing as how the drive was released barely a month ago).

    Tried unchecking the "put hard disks to sleep when possible" during battery and AC power use. Also ran a permissions repair on the OS drive (per Level 2 recommendation :confused:)Didn't fix anything.

    At this point I'm a little concerned, because I "can't" return the drive to the store, now that the RMA has switched it out. If this drive doesn't start working soon, WD needs to somehow take care of this.

    I guess I also have to mention that I'm not inclined to take the Macbook in to the Apple Store yet. Call me overly optimistic, but it's a new notebook, a new drive, and it just shouldn't be like this. At this point I don't have the time to expect Apple to start troubleshooting WD's drive.

    Man it's a fast drive though. No other bus powered Thunderbolt RAID drive out there. :(

    UPDATE

    May 1 Instead of using WD's drive utility, I'm trying setting up the RAID 0 using the OS X Disk Utility. I set it up with a 128k block size for video editing (vs. default 32k). We'll see how this goes.
     
  2. g4cube macrumors 6502a

    Joined:
    Apr 22, 2003
    #2
    Yes, setup with Apple's Disk Utility.

    Check for possible fault Thunderbolt port on your computer. Any issues with other drives?

    I used the WD with my MBPr without issue,a nd I reformatted using Apple Disk Utility. Did not use the WD utilities.
     
  3. happyfrappy macrumors 6502

    Joined:
    Oct 14, 2007
    Location:
    Location eh?
    #3
    In my experience if you setup a RAID its best to use Disk Utility unless the maker requires using their software, however you *may* need to use the WD software to disable any "features" such as idle/sleep (I know with Seagate you need to do this via Windows as it saves the setting to the "dock" chipset firmware)

    "Not Ejected Properly" is from the built-in idle/spin down power saving feature which some models ignore OS X Power Management, a 750GB Passport(1st gen USB 3.0) I own frequently does it when the drive decides to randomly idle/spin down itself... was stuck giving up using it on OS X and it now sits as an expensive XBox media drive as my model was EOL-ed w/o firmware fix.

    As far as Western Digital headaches, I don't recommend their external products as customer service/software tools for Mac users lags behind their PC tools development(remember the Mavericks hell?) and they discontinue models/series to purposely EOL support. They may make the more reliable HDDs but external products are treated like an ugly stepchild. After three nightmares with WD externals, I learned my own expensive mistake.

    When all else fails, LaCie is one of the few makers I trust for RAID unless you dip into NAS territory.
     

Share This Page