20" Aluminum iMac Brightness Changes On Its Own

Discussion in 'iMac' started by shfawaz, Jun 13, 2008.

  1. shfawaz macrumors newbie

    shfawaz

    Joined:
    Sep 8, 2007
    Location:
    Detroit, MI
    #1
    I have a 20" iMac that when I start using it in the morning, I have to turn the brightness back to its highest level from the lowest level. It pretty much stays bright the whole day most of the time (sometimes if I leave the screen blanker function on and/or RSS screen saver it goes back down before the day is out and I have to turn it up again). But almost like clockwork, I have to readjust it again the next morning. Anyone know how I can set this to always stay at the highest or pre-set brightness without having to adjust it every day. This is very annoying. I've tried everything I know with no joy.

    I do have the iMac automatically shutting down off every night around 2am and automatically restarting in the morning around 6am. I don't think this has anything to do with it, but I'm open to ideas or suggestions.
     
  2. brop52 macrumors 68000

    brop52

    Joined:
    Feb 26, 2007
    Location:
    Michigan
    #2
    Stop shutting down. Put it to sleep. Other than that, I have no idea.
     
  3. gehrbox macrumors 65816

    gehrbox

    Joined:
    Jul 5, 2007
    Location:
    Charleston,SC
    #3

    If I read your post correctly you are saying that the brightness level adjustment is moving on its own. If that is correct do the following:

    - Select System Preferences from the Apple menu.
    - Select the Energy Saver Icon.
    - Make sure "Settings for:" says "Power Adapter".
    - Below that select the "Options" toggle button.
    - Uncheck "Automatically reduce the brightness of the display before display sleep"
     
  4. maconhouse macrumors newbie

    Joined:
    May 7, 2009
    #4
    I am having the same exact problem on a 24" iMac, and changing the energy saver did not resolve the issue. I also have my Mac shut down each night (preference of my company). Any other thoughts to resolve this issue?
     
  5. maconhouse macrumors newbie

    Joined:
    May 7, 2009
    #5
    Sleep fixes problem

    I changed my settings so that my computer doesn't restart overnight, and it remedied the problem.

     
  6. brop52 macrumors 68000

    brop52

    Joined:
    Feb 26, 2007
    Location:
    Michigan
    #6
    Why would you set it to restart overnight? What do you do with it now? Put it to sleep?
     

Share This Page