20' Aluminum iMac Stuck at Grey Screen

Discussion in 'iMac' started by zion07, May 21, 2009.

  1. zion07 macrumors newbie

    Joined:
    May 21, 2009
    #1
    My iMac will not boot past the grey screen. No Apple or spinning gear but I get a startup chime. The machine will intermittently reboot and chime but it still remains stuck at the gray screen. This happened the other day and I just left it and came back a couple of hours later and my desktop was up, I just thought it was a glitch. I have tried booting to the CD by holding C on power-up and have reset the PMU and PRam but no dice. Can someone out there help me? Please!
     
  2. txhockey9404 macrumors 6502a

    Joined:
    Feb 25, 2008
    #2
    Put the DVD in and hold option while turning it on. Then, see if you have a HDD icon and a DVD. If only a DVD, click on it, then go to Disk Utility and Verify and Repair your disk and disk permissions if it is there. Then, try booting with option again. If that doesn't work, a factory restore may be in order. YOU WILL LOSE ALL DATA ON THE DRIVE. Go through the setup and then set your computer back up. If it fails setup, make an appointment at a Genius bar and tell them what is happening.
     
  3. redraidermacman macrumors regular

    Joined:
    Sep 20, 2007
    #3
    i would love to know what you found out, i recently sold my old imac to someone and they called me with the same problem after they got it home and i couldnt figure out what to do for him, not sure if he did, but i think he took it to an apple store, the computer was still in warranty, but if its an easy fix i would like to know....thanks!!!
     
  4. zion07 thread starter macrumors newbie

    Joined:
    May 21, 2009
    #4
    Tried Option on boot with no luck :( any other ideas?
     
  5. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #5
    Try a safe boot also, especially if you have log in items or something else that may hang boots.
     
  6. zion07 thread starter macrumors newbie

    Joined:
    May 21, 2009
  7. zion07 thread starter macrumors newbie

    Joined:
    May 21, 2009
    #7
    Scratch that.... I tried safe boot and it still hangs at the grey screen. It will intermittently shutdown ad restart like it really wants to boot...:confused:
     
  8. txhockey9404 macrumors 6502a

    Joined:
    Feb 25, 2008
    #8
    Ok this sounds exactly like what happened to mine 8 months ago. It kept randomly shutting down as if someone was yanking the plug out. It eventually corrupted the hdd and I was able to reinstall via FireWire to a second iMac. I then took it to the genuis bar who replaced the hdd, the logic board twice, the graphics card, all the fans, and the bluetooth chip. Nothing fixed it and after a week of arguing I was awarded a brand new computer.
     
  9. trose macrumors regular

    Joined:
    Dec 28, 2002
    #9
    You could try unplugging the iMac then holding the power button for about 10 seconds.

    I had never used this fix in many years of owning Macs, but it worked when my iMac was not showing any display. Of course, the symptoms aren't exactly the same, as mine was booting past the grey screen. It's worth a shot, though.
     

Share This Page