20" imac new HD - External HD won't mount

Discussion in 'iMac' started by moik, Jan 19, 2011.

  1. moik macrumors newbie

    moik

    Joined:
    Jan 10, 2008
    Location:
    Klamath Falls, Oregon, USA
    #1
    Hello,

    I had a hard drive failure on a 2007 20" imac that had like two weeks left on my applecare plan (what luck!) and had a new HD installed. Great.

    The problem is that my time machine back up failed at the same time. It is a Maxtor "one touch" (I have never used the Windows only "one touch" button that isn't the issue) that will turn on but won't mount on my imac - it also will not mount on my macbook nor will it mount on a windows PC at work. Different wires/cables have been tried including both firewire and USB.

    I'd like to get my data.

    Any recommendations?

    Thanks in advance,

    moik
     
  2. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #2
    I've got the same problem. From reading on the Internet, I've come to the conclusion that this drive sucks. No more One Touch for me. I'm also done with seagate.

    The only thing I can recommend, which is what I'll eventually do, is to take it apart and mount the drive internally.
     
  3. moik thread starter macrumors newbie

    moik

    Joined:
    Jan 10, 2008
    Location:
    Klamath Falls, Oregon, USA
    #3
    >>The only thing I can recommend, which is what I'll eventually do, is to take it apart and mount the drive internally. <<

    I have had that recommended to me. It seems a little tricky with an imac - easier to do with standard desktop unit. Should be fun, though.

    Thanks for your reply.

    m
     

Share This Page