Resolved 2006/2007 Mac Pro (1,1/2,1) and OS X Yosemite

Discussion in 'Mac Pro' started by Mr. Zarniwoop, Jun 3, 2014.

  1. rosah, Mar 5, 2018
    Last edited: Mar 5, 2018

    rosah macrumors newbie

    Joined:
    Jul 27, 2013
    #4401
    Tried the grey, didn't work. Shouldn't I be able to at least boot in recovery? no method is working, HDD, USB or Recovery mode.

    Edit at 4:25PM GMT:
    My bimbo brain has finally retired. I never finished the entire process when creating the install media.

    NOW however, I get an error when booting:
    Code:
    panic(cpu 0 caller 0xffffff800acefec4): "Unable to find diver for thi platform: \"ACPI\".\n"@/SourceCache/xnu/xnu-2782.40.9/iokit/Kernel/IOPlatforExpert.cpp:1590
    Debugger called: <panic>
    Backtrace (CPU0), Frame : Return Address
    0xfffff81afcfbde0 : 0xfffff800a72ad21
    0xfffff81afcfbe60 : 0xfffff800acefec4
    0xfffff81afcfbe70 : 0xfffff800ab386d
    0xfffff81afcfbeb0 : 0xfffff800acb335f
    0xfffff81afcfbf30 : 0xfffff800acae0f3
    0xfffff81afcfbf70 : 0xfffff800acb4003
    0xfffff81afcfbfb0 : 0xfffff800a8116e7
            can't perform kext scan: no kext summary
    BSD process name corresponding to current thread: Unknown
    Boot args:  (null)
    
    Mac OS version:
    Not yet set
    
    Kernel version:
    Darwin Kernel Verion 14.5.0: Wed Jul 29 02:26:53 PDT 2015; root:xnu-2782.40.9~1/RELEASE_X86_64
    Kernel UUID: 58F06365-45C7-3CA7-BB0D-173AFD1A03C4
    Kernel slide:     0x000000000a400000
    Kernel text base: 0xffffff800a600000
    __HIB  text base: 0xffffff800a500000
    
    System uptime in nanoseconds: 515035558
    and then.... nothing...
     
  2. vladyn macrumors newbie

    vladyn

    Joined:
    Oct 11, 2012
    #4402
    I think you should have bootable disk in that case. It's either could be USB (some Mac Pro's can not boot from usb if I remember correctly) Thing I did was creating a small parting on my disk and always keeping it bootable with Pike's version for situations like that.
     
  3. mikecmp macrumors newbie

    Joined:
    May 22, 2018
    #4403
    Hello all,
    New member here looking for a little help. Just got a 1,1 mac pro, already did the flash to 2,1 and updated to the newest SMC as well.

    I have the base Nvidia 7300gt card, 32 gigs of ram and the dual 2.66ghz spec machine.

    I downloaded the patched Yosemite installer from earlier in the thread. I restored it to a couple different drives, including an internal one to boot off of. It loads about a third of the way on boot, then the apple logo and progress bar disappear and no amount of waiting makes it come back.

    I have a MSI Radeon R9 280 on the way and the proper EBC flash rom for it. Will installing the new card get me fully installed, or do I have some other problem.

    Thanks in advance!
    Mike
     
  4. vladyn macrumors newbie

    vladyn

    Joined:
    Oct 11, 2012
    #4404
    Loosing the Apple logo and loading boot screen is normal as you're using non genuine video card. But it's not a problem - you can just wait a bit and the login screen will appear. That's exactly what I'm doing.
    You will have to switch to your original video card in case you don't see the login screen - means you're having some boot problems (or you wanna boot from different source) and these are listed in the srceen after the apple, not visible on non Apple video cards.
     
  5. mikecmp macrumors newbie

    Joined:
    May 22, 2018
    #4405
    Hello!
    I must not have written that very clearly - I am in fact using the genuine card - its the stock Nvidia 7300GT - I get the boot screen with the options to boot. It starts showing the apple logo ,during the install, with a progress bar, on a grey background, then both of those go away and leave the grey background. I went and picked my daughter up from her friends house and left it in that state, came back and it was still a grey blank screen.

    I'm using the already patched Yosemite installed I downloaded from Mega, linked in the first post of the thread.

    I have a non-genuine card on the way, which I will do the EFI flash on. But I am not sure why I'm hitting a wall right now. I have seen reports of people having sluggish performance with the stock card, but that means they at least were able to install and boot, I think.

    Mike
     
  6. vladyn macrumors newbie

    vladyn

    Joined:
    Oct 11, 2012
    #4406
    --- Post Merged, May 23, 2018 ---
    Can't remember was it the base model for this Mac, but also bare in mind that Yosemite with original card for this model 1.1 has smashed graphics and weird behaviour, cause it requires more powerful graphics. May this is the reason.
     
  7. rthpjm macrumors 6502a

    rthpjm

    Joined:
    Jan 31, 2011
    Location:
    U.K.
    #4407
    Try switching the video cable to the other output port on the graphics card. It’s not unusual for the video “path” to change to the other port.

    You’re describing the point where the boot EFI hands over to the Operating System (kernel). At this point the kernel could send the video to the other port.

    You could test, by scooting the mouse all the way and past one side or the other. If the pointer disappears off one edge, then the OS is servicing dual monitors, where the default monitor with the login screen is being sent to the other connection port.

    I’ve seen this myself...
     
  8. mikecmp macrumors newbie

    Joined:
    May 22, 2018
    #4408

    I think you were right - I swapped the ports, still had an error. So I figured I would try again, let it go, went out to play with my daughter, came back to a Yosemite installed. Sweet!

    Thanks - What a simple mistake / fix. Appreciate the tip and the help. Now I'll have to see about el cap in a bit ;)

    Another side note. I got my Radeon R9 280 , but the cable that I bought was not correct, even though it was advertised as a 6 pin min to 8 pin pcie cable for mac pro, it was the normal large connector.

    I ordered another one, we'll see if its right :)

    Thanks!
    Mike
     
  9. canuckofthenorth macrumors newbie

    Joined:
    May 23, 2018
    #4409
    I've tried both SFOTT and the pre-formatted Pike's Bootloader for Yosemite in a 2,1 Mac Pro using USB and have experienced similar problems. Pike's hangs up when the status bar goes one-quarter of the way and shifts to grey screen indefinitely (no mouse action). EDIT: Will try the monitor switch.

    SFOTT hangs up at the same point. On reboot, the Pro generates a report indicating a kernel panic (copied below):


    Wed May 23 17:55:35 2018
    panic(cpu 0 caller 0xffffff800381e80a): Kernel trap at 0x0000000000000000, type 14=page fault, registers:
    CR0: 0x0000000080010033, CR2: 0x0000000000000000, CR3: 0x0000000000a51000, CR4: 0x0000000000002660
    RAX: 0xffffff8014e4a6d0, RBX: 0xffffff7f83ea97e8, RCX: 0xffffffffffffffff, RDX: 0x0000000000000000
    RSP: 0xffffff810d983f08, RBP: 0xffffff810d983f50, RSI: 0xffffff8014e5ab60, RDI: 0xffffff8014e4a6d0
    R8: 0x0000000000000004, R9: 0xffffff8014e5aba0, R10: 0x0000000000000000, R11: 0xffffff7f83ea3b35
    R12: 0x0000000000000000, R13: 0xffffff8014e5ab60, R14: 0xffffff8015c8a5d8, R15: 0xffffff80165c5b00
    RFL: 0x0000000000010246, RIP: 0x0000000000000000, CS: 0x0000000000000008, SS: 0x0000000000000010
    Fault CR2: 0x0000000000000000, Error code: 0x0000000000000010, Fault CPU: 0x0

    Backtrace (CPU 0), Frame : Return Address
    0xffffff810d983bb0 : 0xffffff800373a811
    0xffffff810d983c30 : 0xffffff800381e80a
    0xffffff810d983df0 : 0xffffff800383a443
    0xffffff810d983e10 : 0x0
    0xffffff810d983f50 : 0xffffff8003c4dcb2
    0xffffff810d983fb0 : 0xffffff800383ac46

    BSD process name corresponding to current thread: launchd

    Mac OS version:
    Not yet set

    Kernel version:
    Darwin Kernel Version 14.0.0: Tue Sep 23 23:01:41 PDT 2014; root:xnu-2782.1.97~6/RELEASE_X86_64
    Kernel UUID: 5385C81A-218D-36E7-94EF-C01A5FAA3A8C
    Kernel slide: 0x0000000003400000
    Kernel text base: 0xffffff8003600000
    __HIB text base: 0xffffff8003500000
    System model name: MacPro2,1 (Mac-F4208DC8)

    System uptime in nanoseconds: 5482404643
    last loaded kext at 3789324452: >!UHIDKeyboard 176.2 (addr 0xffffff7f841f3000, size 12288)
    loaded kexts:
    |SCSITaskUserClient 3.7.5
    >PioneerSuperDrive 3.5.5
    >!AFileSystemDriver 3.0.1
    >XsanFilter 404
    @BootCache 36
    >!A!I8254XEthernet 3.1.4b1
    @!AFSCompression.!AFSCompressionTypeZlib 1.0.0
    |IOAHCIBlock!S 2.7.1
    @!AFSCompression.!AFSCompressionTypeDataless 1.0.0d1
    |IOAHCIPassThrough 1.0.3
    >!AFWOHCI 5.5.2
    >!UHub 705.4.2
    >!AACPIButtons 3.1
    >!AAHCIPort 3.1.2
    >!UEHCI 705.4.14
    >!UUHCI 656.4.1
    >!A!IPIIXATA 2.5.1
    >!ARTC 2.0
    >!AHPET 1.8
    >!ASMBIOS 2.1
    >!AACPIEC 3.1
    >!AAPIC 1.7
    >!A!ICPUPowerManagementClient 218.0.0
    $TMSafetyNet 8
    $quarantine 3
    @nke.applicationfirewall 161
    >!A!ICPUPowerManagement 218.0.0
    >!UHIDKeyboard 176.2
    |IOUSBHIDDriver 705.4.0
    >!AHIDKeyboard 176.2
    |IOSCSIBlockCommandsDevice 3.7.5
    |IOSCSIMultimediaCommandsDevice 3.7.5
    |IOBD!S!F 1.7
    |IODVD!S!F 1.7.1
    |IOCD!S!F 1.7.1
    >!UMergeNub 705.4.0
    |IOUSBMass!SClass 3.7.2
    |IONetworking!F 3.2
    >!UComposite 705.4.9​
    |IOATAPIProtocolTransport 3.5.0
    |IOSCSIArchitectureModel!F 3.7.5
    |IOFireWire!F 4.5.8
     
  10. canuckofthenorth macrumors newbie

    Joined:
    May 23, 2018
    #4410
    I tried a completely new restore of Pikes-Alpha Bootloader to the same USB key and succeeded this time. I can't think of anything I did differently. Same graphic card port, original disk image, same machine. I guess it's just finicky!
     
  11. mrkapqa, May 24, 2018
    Last edited: May 24, 2018

    mrkapqa macrumors member

    Joined:
    Jan 7, 2012
    Location:
    Italy, Bolzano/Bozen
    #4411
    i have installed lately mavericks and yosemite on a upgraded 1.1to2.1 2006 model (upgraded the graphics to a non-flashed 5770 radeon hd first) and i have to say that yosemite runs even better than expected!
    really very pleasing!
    you have to look that you don't get a corrupted OSX Installer in the first place (uncorrupted from Mac App Store) and then you should be ready to go.
    Sometimes it happens that Sfott can't download the patched EFI image correctly, then obviously it wont work and one either can try to put manually in the correct place or try again , maybe with different installer image.
    --- Post Merged, May 24, 2018 ---
    plus after installing i did run YosePikeFix.pkg and reboot twice, to allow for seamless updates withouth hassles, if needed.
    --- Post Merged, May 24, 2018 ---
    if you want i can upload you my images aswell, they are for mavericks 10.9.1 and yosemite 10.10, and both should function 100pro, plus one is not already set to 10.9.5 and 10.10.5 , which is not so nice in terms of performance.
     
  12. canuckofthenorth macrumors newbie

    Joined:
    May 23, 2018
    #4412
    It runs shockingly well! I'm using it with a non-flashed ATI Radeon 4870.
     
  13. 21labs macrumors newbie

    Joined:
    Apr 30, 2018
    #4413

    Hi, i installed this before i had yosemite installed properly, and now i am in a boot loop how do i uninstall this?
     
  14. rthpjm macrumors 6502a

    rthpjm

    Joined:
    Jan 31, 2011
    Location:
    U.K.
    #4414
    Let me ask a few questions...

    “Before I had Yosemite installed properly”, do you mean on the MacOS version prior to updating to Yosemite?
    If so, what version of MacOS?

    To fix it, you need to boot from another partition, maybe the Recovery HD, then find a copy of the boot.efi file that is compatible with that version of MacOS. Copy that boot.efi file into two locations (overwriting) the ones that are there...

    (If you have a working Recovery HD, there is a compatible boot.efi file located there...)

    If I assume that the broken partition mounts at /Volumes/Macintosh HD

    Use the Finder or the Terminal to copy the “good” boot.efi file to
    /Volumes/Macintosh\ HD/System/Library/CoreServices/boot.efi
    And
    /Volumes/Macintosh\ HD/usr/standalone/i386/boot.efi

    NOTE: the space between Macintosh and HD has been “escaped” by placing a back-slash before. It is appropriate for the Terminal because the Terminal shell normally treats the space character as a word separator.
     
  15. mrkapqa macrumors member

    Joined:
    Jan 7, 2012
    Location:
    Italy, Bolzano/Bozen
    #4415
    I am running it on 5770 HD non-flashed, which gives only 2,5gb/s link, but still around 30.000 points in OpenMark Benchmark. Now i am starting to get fond of Yosemite, slowly.
     

    Attached Files:

  16. mlmacml macrumors newbie

    Joined:
    Oct 22, 2018
    #4416
    hi! to install on macbook 2,1 where do i get the official yosemite OS? It's not available in mac app store. i'm running SL right now,
    macpostfactor doesn't support pirated copies, right?
     
  17. canuckofthenorth macrumors newbie

    Joined:
    May 23, 2018
    #4417
  18. mlmacml, Oct 24, 2018
    Last edited: Oct 25, 2018

    mlmacml macrumors newbie

    Joined:
    Oct 22, 2018
    #4418
    thanks!

    even though i have a 15.5GB USB drive connected, macpostfacotr doesn't allow me to install on an external drive... not sure why?

    another thing.... i read on the osxhackers site, "if your mac blows up, it's your responsibility!"... something like that. i know it's a figure of speech, but does this mean if i mess up, my macbook 2,1 would become unusable? i have no data on there, so data recovery is not a concern, but if i do this whole macpostfactor installation incorrectly, would i not be able to even go back to my current snow leopard, and my mac would be "bricked"?

    i'm a total noob so i'm worried about that :(
     
  19. mrkapqa macrumors member

    Joined:
    Jan 7, 2012
    Location:
    Italy, Bolzano/Bozen
    #4419
    on a macbook2,1 i would not taking these steps for installing with macpostfactor, i'd rather stick with snowLeopard as it is best MacOS for older Intel Macs in terms of stability and speedyness.
     

Share This Page