2006 MacBook drops wifi

Discussion in 'MacBook' started by idiwa, Jan 10, 2011.

  1. idiwa macrumors member

    Joined:
    Sep 21, 2006
    Location:
    Glasgow. UK
    #1
    Looking for help with this please.
    MacBook. 2Ghz Intel Core Duo. OS Snow Leopard 10.6.6

    I'm running a 2006 MacBook with Snow Leopard. A few months back it started dropping wifi connection. Airport would show no connection but would list my network along with others in my building. If I tried to connect with my WPA password it would just time out. At this time I was running Leopard.

    Since then I've done a few things.
    • Tried running the Netgear router with no encryption at all (same thing happens). Will lose connection and then time out trying to connect
    • I've tried the MacBook in a coffee shop with wifi access and at my parents (same NetGear router) and at my new apartment with a horrible Orange Livebox.
    • Taken the MacBook in to see the genius bar at Glasgow Apple store. Worked fine for them, but I explained it was intermittent but we could not force it to fail. I'm sure if it ran for an hour it would.
    At present if I have the MacBook in the living room (where the Livebox router is situated) its fine and wont drop connection. If I walk some 5m to my bedroom it will work for approximately half and hour and then lose it. A few days ago I bought the Snow Leopard upgrade and installed it last night. MacBook runs a hell of a lot faster (yay!) but moving it away from the router and its dead as disco in half an hour.

    So to clarify, the MacBook has been tested on 4 wifi networks/ locus with same issue. iPhone, Xbox 360 and PS3 all have no issues with dropping connection no matter where they are in the apartment.

    Apartment is a new build and its walls are not made out of lead or kryptonite. Is this a hardware issue rather than software? When updating to Snow Leopard it was an update to the existing OS of Leopard not a clean install. Thanks for your help in advance, cheers.

    AIRPORT says the following in System Profiler.

    Software Versions:
    Menu Extra: 6.2.1 (621.1)
    configd plug-in: 6.2.3 (623.2)
    System Profiler: 6.0 (600.9)
    Network Preference: 6.2.1 (621.1)
    AirPort Utility: 5.5.2 (552.11)
    IO80211 Family: 3.1.2 (312)
    Interfaces:
    en1:
    Card Type: AirPort Extreme (0x168C, 0x86)
    Firmware Version: Atheros 5424: 2.1.14.5
    Locale: ETSI
    Country Code: GB
    Supported PHY Modes: 802.11 a/b/g
    Supported Channels: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140
    Status: Connected

     
  2. robertwhyte macrumors newbie

    Joined:
    Jun 13, 2007
    #2
    I had problems with 10.6.6 and after trying everything else finally reestablished normal life after I deleted all my keychain items except necessary certificates and keys and logged into the airport afresh.
     
  3. X2thaP macrumors member

    Joined:
    Nov 28, 2010
    #3
    When did it start to happen? ("a few months back") Perhaps when you updated to 10.6.3 or 10.6.4?

    Reason I ask is because I've had this happen to me, on a 2008 MacBook (purchased with 10.5.4 installed), as well.
    It happened as soon as I updated from 10.6.2 to 10.6.3. The following updates never fixed it, so I was working
    with all different suggestions floating around on the internet, but non of them where a permanent fix.

    I decided to 'downgrade' back to 10.6(.0) and everything worked perfectly. I kept it at 10.6 until the Mac App Store came out
    and I was 'forced' to update because I wanted the App Store. I then found out that going from 10.6 straight to 10.6.6 did not
    mess up the WiFi/Airport! So it is back to normal now.

    *EDIT* Just missed the part where you wrote you just recently did the Snow Leopard install, so it can't be due to the update I suggested.
    I do however remember some posts about the same thing happening on the 10.5(.8??) updates as well I believe.
    In this case I have no practical solution for you, sorry.
     
  4. logana macrumors 65816

    logana

    Joined:
    Feb 4, 2006
    Location:
    Scotland
    #4
    Most likely cause of the problem is the Atheros wireless card fitted in your (and most) Core Duo MacBooks.

    Simplest answer is to open it up and replace with a Broadcom n card.

    Some of the Atheros cards work fine with Snow Leopard but many just time out or connect on the 3rd attempt.

    You should be able to get a replacement card fairly cheaply off eBay.
     

Share This Page