2007 "Santa Rosa" Macbook Pro - Doesn't Realize It's Been Unplugged/Plugged in.

Discussion in 'MacBook Pro' started by evilspoons, Oct 9, 2011.

  1. evilspoons macrumors member

    Joined:
    Sep 3, 2007
    #1
    Hey everyone,

    I have a 2007 2.2 GHz Macbook Pro. Originally had 2 GB of RAM, now has 3 GB. I have a Seagate Momentus XT 500 GB hard drive replacing the original 120 GB one as well. Original OS was 10.4, now running 10.7.

    Somewhere along the way the computer developed the habit of not realizing when the magsafe adapter has been connected or disconnected. I am running on battery right now (have been for an hour or so) and it still says "Charged" in the menu bar. The battery says I'm at 3 out of 5 dots when I press the 'check' button on it.

    I've also had times where it has successfully realized it's on battery (turning the machine off and on again will help) and then I plugged it back in. Just like disconnection, it might realize right away or sit there for 15 minutes thinking it's still on battery while the magsafe light shows orange for charging.

    It did the same thing on 10.6 so it's not 10.7 specifically.

    Any ideas? I've had no luck searching for this, it seems to be a strange issue to form a good search for.
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    My mid-07 Blackbook does this same thing. I've tried everything to fix it. I've cleaned the MagSafe pins, cleaned the battery terminals, reset the PRAM/PMU, even let the thing completely die. Nothing's fixed it yet.
     

Share This Page