Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

stevewray7800

macrumors newbie
Original poster
Nov 2, 2015
2
0
Hi,

I have an early 2008 IMAC (2.8GHz Intel Core 2 Duo,2GB 800 MHz DDR2 SDRAM) currently running 10.6.8 . . .which is the most recent OSX can I update to?

Many Thanks.
 

G.McGilli

macrumors 6502
Oct 19, 2015
479
314
El Capitan 10.11.1

That's what I have on my 2007 iMac and works perfectly.
 
Comment

ferretex

macrumors 6502
Apr 9, 2015
251
109
OS X 10.11.1, but I wouldn't update it without 4GB of RAM and a SSD. In my case 6GB RAM and SSD. Early 2008 iMac like you here.
 
Last edited:
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.