2008 Mac Pro: SATA BluRay drive falsely detects blank CD, won't eject

Discussion in 'Mac Pro' started by six50joe, Apr 3, 2013.

  1. six50joe macrumors newbie

    Joined:
    Feb 2, 2005
    #1
    I recently installed a Pioneer Blu Ray drive (BDC-207DBK) to replace the original Pioneer combo drive that came in this Mac, which no longer works.

    To install it, I needed to use a SATA cable to connect it to one of the two SATA ports on the motherboard.

    The drive physically works fine after every reboot. However, after I leave the Mac for a while and come back the following happens when I want to insert DVD:

    I know from my previous use that the drive has no DVD in it. I press eject, but instead of ejecting I get the popup that indicates I've inserted a blank CD. I choose Ignore.

    I open disk utility and see that the drive itself is no longer mounted.

    From this point, every press of eject opens the popup. No action I've tried at this point will mount the drive or eject its DVD tray- that is, until I reboot. Then, everything works fine until I leave it for a while and come back.

    I would think this is a software problem because it functions fine as long as I stay at the machine after reboot.

    The Mac's firmware seems to be up to date.
    I've tried zapping the PRAM a few times, but no change.

    Anyone else had this issue and know how to solve it?

    Thanks!
     
  2. justperry, Apr 3, 2013
    Last edited: Apr 3, 2013

    justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #2
  3. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #3
    I'd check the system preferences for CDs and DVDs and ensure the "When I insert a disc" settings are all set to do nothing automatically.
     
  4. six50joe thread starter macrumors newbie

    Joined:
    Feb 2, 2005
    #4
    I had been hoping there would be a firmware update, but doesn't seem to be the case.

    AM, not sure how changing the preference for CD insertion would allow the drive tray to eject, but anything's worth a try at this point. I'll see if that makes any difference when I get home.
     
  5. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #5
    I don't think it will fix the problem, but it is simple and worth a try.

    The reason why I suggested it is that I know those preferences can alter the "inserted a blank CD" popup behavior, which seems to be directly related to your eject problem. In fact, no matter what the settings are there, I'd try changing them just to see if the behavior changes.
     
  6. six50joe thread starter macrumors newbie

    Joined:
    Feb 2, 2005
    #6
    The prefs were all set to Ignore for new CD. Setting them to open a certain app caused it to do that, but unfortunately doesn't help to remedy the problem.

    I'm a little surprised that I haven't seen a lot online about others having this issue; I can't imagine I'm the first one to ever replace the Pioneer Superdrive that came with my Mac Pro with another Pioneer drive, using a SATA port. While I can't completely rule out a problem in the hardware, it seems exceedingly unlikely. The only variable that seems to cause the issue is OSX going to sleep after a period of inactivity. That leads me to think there must be something in the hardware or software configuration that would address it.
     
  7. oodz macrumors newbie

    Joined:
    Apr 14, 2014
    #7
    Pioneer Optical Drive Issue Solved!

    I have faced the very same problem when trying to upgrade the optical drive of a pair of Mac Pros (early 2008). In both cases I upgraded from the original Super Drive to a Pioneer brand BluRay burner (Different models, same brand). In both cases was necessary to connect SATA controller cable directly from Mac Pro´s motherboard and a power adapter to match the sata energy connector.

    Well, the problem of the Mac Pro disappearing new optical drive after a while and/or making the system unstable after upgrade, was solved permanently doing this: Keeping the original SuperDrive connected (IDE interface) and setting the old optical drive to "Slave mode" (jumper managing) and connecting of course the new optical drive like it was, from the motherboard using SATA cable.

    You will have to keep both optical drives and turn off the "Put disks to sleep when possible" feature in System Preferences panel. This way problem is solved for sure.

    When the eject key is pressed the SATA optical drive (Pioneer BluRay burner) will open, and to open/close the SuperDrive you will have to use the eject icon that will automatically appears after adding more than one optical drive in the menu bar.

    Hope it helps!
     

Share This Page