2008 MacBook Pro 17inch Very Slow, even after SSD upgrade.

Discussion in 'MacBook Pro' started by renosausage, Oct 21, 2013.

  1. renosausage macrumors regular

    Joined:
    Sep 22, 2012
    #1
    Hey everyone, I need some help here:

    I've got a 17 inch MacBook Pro Intel Core 2 Duo

    4GB of RAM. Every time I turn it on the gray screen with the Apple Logo loads for about 5mins then the screen turns blue and it takes another 7 mins for my desktop to show up.

    Even after my desktop shows up, it still takes another 5 to 10 mins until the dock becomes responsive.

    I thought it was a HDD issue so I updated it to a Samsung 120 GB SSD. I booted the laptop from my Snow Leopard install CD and wiped the SSD to Mac Journaled. I then install that OS fresh on the SSD.

    Laptop still does the same thing. I've tried SMC reset and PRAM. I even tried new RAM. Apple offered $310 to fix it, but I was wondering if any of you guys may have an idea of what it could be.

    Thank you :)
     
  2. B... macrumors 68000

    B...

    Joined:
    Mar 7, 2013
    #2
    Just make sure the SSD is selected as the startup disc in System Preferences.
     
  3. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #3
    You said, Apple offered to fix it for $310... What did they say was wrong with it?
     
  4. renosausage thread starter macrumors regular

    Joined:
    Sep 22, 2012
    #4
    They didn't say, it was too slow to even do a hardware test.

    The $310 is just a flat rate.

    It's actually a pretty good deal, I was told they would replace anything and everything that needed to be replaced with no extra costs.
     

Share This Page