2008 MacBook Unibody - Negotiated 1.5GB/s link speed

Discussion in 'MacBook' started by keysofanxiety, May 12, 2015.

  1. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #1
    Good afternoon MacRumours,

    I fitted an SSD in my friend's 2008 Aluminium Unibody MacBook. It looks like it's a 3GB/s interface on the SATA, but it's running at a negotiated 1.5GB/s. A look online seemed to indicate that this is a hardware bottleneck due to the nVidia firmware. May I confirm if this is the case, or if anybody knows of a way to fix it?

    The system is on the latest version of Yosemite and all firmware updates have been applied.
     
  2. bibyfok macrumors 6502

    bibyfok

    Joined:
    Jun 14, 2012
    Location:
    France
    #2
    As far as I remember, I think there was a defect on the SATA cable. I think changing the cable resolved the issue.
     
  3. keysofanxiety thread starter macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #3
    Oh dear, that's bad news. Thank you for the heads-up though. :)
     
  4. bibyfok macrumors 6502

    bibyfok

    Joined:
    Jun 14, 2012
    Location:
    France
    #4
    This is not a definitive answer, I just recall that some Macbook (pro?) had a defective SATA II cable that gave a 1.5gb handshake.
     
  5. keysofanxiety thread starter macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #5
    Ah ... so there's hope yet! I'm pleading with the computer gods that there's a simple third-party firmware update or something which will fix the issue. :eek:
     

Share This Page