2008 Unibody Macbook: No Airport Card Installed

Discussion in 'MacBook' started by theaero, Jun 12, 2010.

  1. theaero macrumors 6502

    Joined:
    Mar 5, 2008
    #1
    My sister is having this error. I cant figure out why. She spilled some soup on her computer, and I guess that is when the problem started. I don't know if anything was permanently damaged... could reseating the airport card help? I've reset pram, smc, repaired permissions, and done every software troubleshooting thing I can do. I ran the apple hardware test as well, and it said no problems. Bluetooth / ethernet work with no issues as well.

    Any suggestions would be great.
     
  2. AshMan macrumors regular

    Joined:
    May 1, 2010
    #2
    You may want to open the MacBook up and check for liquid damage then clean it real good. You can probably use sown kind of contact cleaner/rubbing alchohol. Could be the airport card is what got liquid on it.

    One of the many reasons I do not put anything with liquid down anywhere near my MacBook
     
  3. theaero thread starter macrumors 6502

    Joined:
    Mar 5, 2008
    #3
    Where is the airport card located inside the late 2008? I couldnt find it on ifixit
     
  4. theaero thread starter macrumors 6502

    Joined:
    Mar 5, 2008
    #4
    No one knows where this mysterious airport card is? :)
    Is it on the logic board somewhere?

    EDIT: took out logic board + everything, washed everything with alcohol, and now its working fine. :)
     
  5. spirochete macrumors newbie

    Joined:
    Nov 11, 2003
    Location:
    London England
    #5
    The board is inside the screen's hinge cover on a Unibody..... small, about 30mm long and 12 mm wide. Note also that it has a heatsink connection to the screen's frame, so be careful if disturbing it.
     

Share This Page