2009-2010 Mac Pro Firmware Tool Error: This program requires Internet Access

Discussion in 'Mac Pro' started by Okta, Mar 23, 2018.

  1. Okta macrumors newbie

    Joined:
    Apr 20, 2014
    #1
    Hey there everyone,

    I'm trying to flash my 2009 4,1 to 5,1 but I keep running into this issue with the firmware tool. It says

    'This program requires Internet Access. Please connect your Mac Pro to the Internet and Try Again'.

    I am connected to the internet. I read that the typical fix was to download the 1.5 2010 Firmware from here: https://support.apple.com/kb/DL1321 and then mount it, but don't click the .pkg. I did that exact process and I get the same error.

    Any ideas on how to help?

    Thanks!
     
  2. Okta thread starter macrumors newbie

    Joined:
    Apr 20, 2014
    #3
  3. ActionableMango macrumors G3

    ActionableMango

    Joined:
    Sep 21, 2010
    #4
    No, don't mount it. Just put the file on the desktop.
     

Share This Page