2009 iMac USB 3 Incompatability

Discussion in 'iMac' started by wizzwas, Aug 23, 2012.

  1. wizzwas macrumors newbie

    Joined:
    Aug 23, 2012
    #1
    I've got a late 2009 i5 27" iMac. My problem is that I have two USB 3 devices that do not work when plugged into my iMac on any of the 4 USB ports.

    I only just got a Sandisk Imagemate USB 3 card reader today and that doesn't work which made me think that it's the Macs problem. As I got a Freecom mg USB 3 HDD a couple of years ago that doesn't work over USB either (I just use the firewire) which, at the time, I thought was a problem with the hard drive. But now, it's obviously something to do with the mac.

    I've looked all over the net to see what might be wrong and only found one thread over in the MBP section on here that seemed like the same thing, but no one had a solution. (http://forums.macrumors.com/showthread.php?t=1391284)
    There it mentioned what I thought might have been the problem of the USB ports not providing enough power to the devices.
    However the Freecom HDD has a USB 3 connection as well as a USB power connection and it doesn't work with either USB 3 on its own or with the power USB plugged in too.

    Furthermore I thought that this was my bad luck at getting a faulty mac (it's already had a hard drive meltdown) but my almost year old MBA doesn't recognise any of the devices either. Although I did see an LED light up on the card reader when it was plugged into the Air.

    Also, it doesn't show anything is connected in System Information either.

    So what the hell do I do?
     
  2. forty2j macrumors 68030

    forty2j

    Joined:
    Jul 11, 2008
    Location:
    NJ
    #2
    It's up to the peripheral maker to ensure USB 2 backward compatibility. And generally they do.. I have a USB 3 external drive that works fine on my 2007 iMac.

    Have you tried known USB 2 devices to ensure you don't just have dead ports?
     
  3. wizzwas thread starter macrumors newbie

    Joined:
    Aug 23, 2012
    #3
    I've not seen any of the same problems from owners of the same peripherals though. And I just tried them on a USB 2 Dell laptop and they worked fine.

    All my USB ports work fine with USB 2 devices. Like I said I've tried both things with my MBA and it doesn't recognise them either.


    Will there be drivers or something that I can download and install manually?
     
  4. wizzwas thread starter macrumors newbie

    Joined:
    Aug 23, 2012
    #4
    Just managed to get it working, but only if I don't plug in the USB cable all the way into the port.
    Transfer speeds seems normal too. About 15-20Mb/s.

    Anyone know what cause of this problem may be? I also tried the same technique on my MBA and it worked on that too. Very strange.
     

Share This Page