2009 Mac Pro not sleeping

Discussion in 'Mac Pro' started by elliots11, Jan 18, 2016.

  1. elliots11 macrumors newbie

    Joined:
    May 23, 2011
    #1
    I have a 2009 Mac Pro and I've had issues with it not sleeping. The screen will go blank and appear off, but it doesn't do the rhythmic "light breathing" and it doesn't do the power supply click that it usually does when it's actually asleep.

    I'm running:
    2009 Mac Pro 8 core
    32GB RAM (4 x 8GB DDR3 ECC, aftermarket)
    Nvidia GTX 980Ti
    Nvidia GT120 OEM (nothing plugged into it)
    BlackMagic DeckLink Mini Monitor connnected to HDMI TV set
    USB 3 card - inateck 2 port
    SSD - Crucial
    2 or 3 Western Digital Hard Drives
    USB Hub - Sabrent HB-MAC7
    Avid Artist Color Control Surface
    Apple Cinema Display 30"
    Apple wired keyboard and mouse
    DaVinci Resolve Dongle


    - I initially had these issues when running 10.8.5 and a Nvidia GTX285 video card. Occasionally I'd reinstall 10.8.5 and maybe the problem would go away and maybe it wouldn't, but sooner or later it'd come back.
    - I upgraded to OS X Yosemite 10.10 and that seemed to fix the issue, or did for several months up until 2 or 3 days ago. I've also changed out video cards to a Nvidia GTX980 Ti, but that went smoothly several weeks ago with no effect on sleep.
    - Issue seems to have come on with no apparent cause. Nothing has changed in this setup in the last few days except the recent addition of the USB hub, and I tried unplugging that and it still is acting the same way. I also plugged back in an internal hard drive I hadn't used in a while (storage, not OS), but upon removing that the problem remains. Unclear if issue was happening before I started using the old hard drive again.
    - When I do a system report it says "There was an error while gathering PCI device information." but everything is functional cardwise, except no proper sleep.

    - Things that have changed since last this was a problem (6 months ago or more): Yosemite upgrade from Mountain Lion (fixed issue initially), BlackMagic Deckling mini card added, USB3 card changed from 4 to 2 port version (yosemite compatibility), Hard drives moved in and out, Cinema Display added (3 other monitors subtracted), Control Surface added.
    Additionally the problem was unaffected by the 32GB of RAM upgrade or the SSD upgrade, as in it occurred both before and after.

    It seems something is breaking in the OS, or there's some sort of a hardware conflict going on. It does not appear linked to any of the accessories I'm using. Does anyone have any experience with this? I searched for it and didn't see anything.

    Thanks!
     
  2. lowendlinux Contributor

    lowendlinux

    Joined:
    Sep 24, 2014
    Location:
    North Country (way upstate NY)
  3. elliots11 thread starter macrumors newbie

    Joined:
    May 23, 2011
    #3
    The pmset -g assertions didn't turn up anything, but while searching for what that meant I found instructions to do an SMC reset which appears to have fixed it. I had tried that last time but it didn't work, however this time is different almost entirely and it worked great. Thanks!
     

Share This Page