2009 Mac Pro updated to 5,1 with a new CPU board does not boot

Discussion in 'Mac Pro' started by resonate, Jul 5, 2014.

  1. resonate macrumors newbie

    Joined:
    Dec 17, 2007
    #1
    i have a 2009 mac pro. I updated the firmware to 5,1. Then, my cpu board stopped working, so i got a new one. a 2009 one. Everything is put on correctly, but the computer does not boot. no cpu lights, but no boot. Is there a firmware problem? What to do?
     
  2. omvs macrumors 6502

    Joined:
    May 15, 2011
    #2
    It might be a firmware mismatch - I recently bought a spare 2009 board off ebay and faced the same issue - didn't connect the dots that it probably has old firmware until seeing your post with the same circumstances. Since my current board has hex-core cpu's, I can't really downgrade to test.

    Wonder if one could do the hold-power-down trick to update the firmware w/ new board. I may give that a try now.
     
  3. omvs macrumors 6502

    Joined:
    May 15, 2011
    #3
    Actually, is your board giving the red light? It might be the plastic rivet holding the chipset heatsink popped off, and its a relatively easy repair... Happened to me last week and freaked me out, though I remember reading about it online and knew what to look for.

    The rivets are apparently hard to find, but you could steal one from your new board. Or I replaced mine with a 4mm screw & nut from hardware store - just be careful to to make it too tight.
     
  4. resonate, Jul 5, 2014
    Last edited: Jul 5, 2014

    resonate thread starter macrumors newbie

    Joined:
    Dec 17, 2007
    #4
    well, the rivet was a reason i got this new board.

    the new board with 2 cpu fitted doesnt give me any red lights, not from processors, or from anywhere. the cpu leds blink and turn off when i turn the machine on. it just doesnt boot.

    the onther thing that puzzles me is when i push the diag button the 3rd DIAG LED from the top is flashing green (right left to the DIAG button)

    i just wish somebody confirmed it's the 2010 firmware thing (you kinda did)

    I don't know what to do now, i have a friend with 2009 mac quad, but when i upgrade his firmware, he wont be able to boot his board - if that's true. it's a catch 22 situation......
     
  5. omvs macrumors 6502

    Joined:
    May 15, 2011
    #5
    Its possible that we both have bad boards - I was assuming mine was bad until reading your post, but now I think its more likely firmware.

    Unfortunately its hard to swap my boards at the moment, so I can't test solution - maybe i'll drag it out and try a few tricks later today.

    I definitely wouldn't risk screwing up your friends machine ;)
     
  6. resonate, Jul 5, 2014
    Last edited: Jul 6, 2014

    resonate thread starter macrumors newbie

    Joined:
    Dec 17, 2007
    #6
    I solved the issue

    SOLVED!

    Okay, so the thing is - you have to screw the heatsinks well enough. But be careful, and do it in turns. So the last time, when i got to the point that computer turns on and stops (no video, no chime) but no longer puts out any warning leds, it means you have to screw the heatsink to the processor a little more. Start with just processor A, and slowly but surely, add more turns as does this guy in the video here : https://www.youtube.com/watch?v=YAdgT-hJuXU
    I had the same exact symptoms - at first, when the cpu is not fastened enough, you can get a pulsing power light and possibly fans loud on, then you make another half turn-full turn (be careful) and you get past that, the next symptom may be that the cpu board does not recognize all the memory, you have to screw some more, remember that slots 1-4 belong to CPU A, 5-8 to CPU B, so if your board does not recognize slot 5, that means CPU B needs a little more love :) be careful ! slowly and surely, thats the clue

    another thing - I was told by the seller from ebay that SMC version on cpu board does not matter, it should boot anyhow. That was the impulse i needed. I started with CPU A, and went thru the steps that i written about above. Then had a lot of reserve ( I was cautious) about screwing the CPU B harder, but looks like it needed a little more than CPU A, go figure. I tried it four times with different CPUS (i thought that maybe they were broken) and after giving it a bit more turns finally the board saw both cpu's.

    After i booted into os x, i saw that my smc version for the logic board (that i updated to 5,1) was the same (1.39f5) as the smc that came with my new cpu board 2009 from the shop - 1.39f5, too. my boot rom is MP51.007F.B03. Looks like i have a spare double cpu board now with 2 cpus :)

    A lot of screwing, i know :)
    but maybe it will help somebody, i know i needed help badly a week ago. Learned a lot. ask any questions if something is not clear.

    Cheers!

    B
     

Share This Page